Engine diagnostic light does not always come on when you first turn on ignition

Discussion in 'Softail Models' started by WaltGrosch, Jun 29, 2011.

  1. WaltGrosch

    WaltGrosch New Member

    4
    0
    0
    I just purchased a 2011 FLSTC with the smart security system installed and when I turn the ignition on, sometimes the engine diagnostic light comes on for 4 seconds like it should, sometimes 1 second, most of the time it never comes on. Also, when the key fob is not near the bike and I turn on the ignition it "says" EN*ER PIN, where the * is actually an unside down F instead of a T. The dealer replaced the body control module, but it made no difference. Harley is stumped. Anyone else have a similar problem?
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Did you enter your personal PIN number in the bike? Did the dealer enter a PIN?
     
  3. lordharold

    lordharold Active Member

    191
    0
    2
    I agree with Glider the dealer should have set the security upon delivery they should of asked you for a 5 digit pin # to set your fobs and security.
     
  4. BOWHIKER

    BOWHIKER Junior Member

    434
    28
    4
    Sounds to me that MOCO is making these touring bikes so high tech even the dealers don't know how to work on them .
     
  5. glider

    glider Veteran Member

    25,464
    108
    44
    Amen to that. I have seen some issues on bikes when I visited the dealer that left me scratching my head why the tech didn't know what was causing it.
     
  6. lordharold

    lordharold Active Member

    191
    0
    2
    YES! that is why it is a good idea to keep the finger nails short
     
  7. WaltGrosch

    WaltGrosch New Member

    4
    0
    0
    When I first got the bike the diagnostic light came on everytime I started the bike. It wasn't until I had 300 miles on the bike that I realized the security system wasn't working! I took it to the dealer, he enabled it, set their own pin, then the trouble started with the diagnostic light. I did set the pin to my own personal pin but it made no difference.
     
  8. Hoople

    Hoople Account Removed

    7,198
    0
    34
    You have a 2011 and that is a different animal. But... if you perform a WOW test and try to read codes, do you receive any "noRSP" replies from any reporting devices? If you do have any DTC's,, what are they.
     
  9. WaltGrosch

    WaltGrosch New Member

    4
    0
    0
    OK, the dealer replaced the BCM, no difference, then they replaced the speedometer?, no difference, then the replaced the ECM, no difference. They said Harley will work on it and let them know.
     
  10. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Wow, interesting bug for sure. Thanks for keeping us in the loop. On the 2011's, the difference between "ignition" and "accessory" is a fixed 200 ohms resistance built into the ignition switch due to the HDLAN design. I have this funny feeling that......:):)