Engine Cuting out during acceleration

Discussion in 'Engine, Fuel and Exhaust' started by Electraglidedude, Aug 16, 2013.

  1. Electraglidedude

    Electraglidedude Member

    11
    0
    0
    I was riding my 2004 electraglide the other day and it started cutting out.. It in intermittent and I just thought I got some bad gas.. It doesn't die, just cuts out during acceleration. I have replaced coil, wires, plugs, engine temp sensor, throttle sensor and drained the tank. It still cuts out... mainly during acceleration and when its cold.. but still does it when at operating temp. I took it to HD and they said I need a new battery, so I put one on and it still does it...Does anyone out thee have information that could help?
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Welcome to The Forum Harley Davidson Forums
    Have a look here first then check back in:s
     
  3. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,598
    103
    296
    :wce From Colorado, any mods. done to the bike?
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  5. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Jack has you covered. Check for DTC codes and the chance of pin-hole leaks or low fuel pressure.
     
  6. Electraglidedude

    Electraglidedude Member

    11
    0
    0
    I cut the cross over exhaust tube off and made it true duels, and put freedom mufflers on it. also, I put power cones in to improve back pressure.
    It ran fine for about 400 miles and suddenly started with the sputtering. I put a vance & hines fuel pak on it and that made a big improvement on hou it ran, but it still sputters from time to time. mostly when it is cold.
     
  7. Electraglidedude

    Electraglidedude Member

    11
    0
    0
    I took it to HD yesterday and they checked the fuel pressure and said it was fine...
     
  8. Hoople

    Hoople Account Removed

    7,198
    0
    34
    It sounded like you just got a new battery at the dealership. Besides fuel pressure, what else did they do or check. Giving us all the info at 1 time, makes it easier.

    What was your fuel pressure. No DTC codes or were they erased when you went to dealership. If erased, what were the numbers.
     
  9. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Verify the fuel pressure test with numbers? Disconnect your fuel pak how does it run now? Check again for codes?
     
  10. Electraglidedude

    Electraglidedude Member

    11
    0
    0
    The HD tech just said they were going to check the fuel pressure..I didn't think to ask what the pressure was.. It's probably not hard to tell that I am new at this, so I hope everyone will bare with me on this problem.
    The only code that they could find was a throttle position sensor. he said it would show up until he started it and the code would go away. and come back when he shut off the engine...
    They replaced the sensor and I replaced the battery.
    I noticed today that the sputtering is worse when it is cold and is worse around 2800 RPM... and when leaving a stop, as I let out the clutch, it has a significant stumble and then takes off... I hope someone can help with this..I am at my wits end... Thanks for everything!