ENG light comes on while riding

Discussion in 'Touring Models' started by dcollie3, Apr 8, 2009.

  1. dcollie3

    dcollie3 Member

    20
    11
    0
    Hi all. I just bought my first dream bike (1998 Road King Classic) with a stage 2, sceaming eagles etc. I took it out for a good scoot yesterday and while crusing at 70 mph the ENG light came on and the bike seemed to loose power for a few seconds and then resumed as it nothing happened. This happend a few times. A couple of times it seemed to loose power and a few time the light came on but didn't seem to loose power. I've read a few of the threads relating to engine lights but I'd like to get other optinions.

    Thanks, ridge-walker
     
  2. fiveoh455

    fiveoh455 Active Member

    116
    28
    1
    I had something similar happen to me last summer, returning from the Ohio HOG Rally in Sandusky, Ohio. My bike, a 2001 Road King Police bike was fine all weekend until I got on the Ohio turnpike. My engine light came on, and the bike seemed to "lose power." I pulled off, shut it down and checked battery connections etc. Went to start it back up....nothing. Long story short, had to trailer the bike home (thank goodness for friends with a trailer.) Turns out the stator was bad and wasn't keeping the battery charged. Dead battery=no ride. Hope this helps.
     
  3. glider

    glider Veteran Member

    25,464
    108
    44

    The only other options are to see if there is a code stored and what it means. Try this.

    00-03 HD Codes And Activation - Harley Davidson Community
     
  4. dcollie3

    dcollie3 Member

    20
    11
    0
    thanks very much folks I'll give it a shot.
     
  5. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,630
    68
    99
    It is a carb bike or FI?

    TQ
     
  6. wildspirit97

    wildspirit97 Senior Member

    1,088
    46
    0
    If it hasn't been done for a while, or if your unsure about if it's been done it wouldn't hurt or cost too much to go down and get a new set of plugs and wires and put them on to start with if you don't have any luck finding codes.
     
  7. STEVE07

    STEVE07 Well-Known Member Staff Member Super Moderators

    4,033
    68
    41
    If your fuel pump loses pressure it would give you the symptoms you are describing,including the engine light and occasional loss of power.I would check the fuel filter ,it is an 11yr. old bike and you don't know if it has been serviced or what has been dumped in the tank over the years
     
  8. dcollie3

    dcollie3 Member

    20
    11
    0
    Hi it is a FI and it did happen again yesterday. I do plan to take it to the shop for a good tune up and I'll ask them to replace plugs and wires.
     
  9. ALL IN

    ALL IN Member

    14
    11
    0
    hey guys just did a check of codes and i am coming up with a 16 witch to my knowledge is low or high voltage so does this mean in the battery or charging system?i am going out to check battery with a meter now but was hoping to get this solved tonight i will get back with batt. reading!!!!!!!!
     
  10. glider

    glider Veteran Member

    25,464
    108
    44
    Generally it refers to the charging system unless there's a problem with the batteyr itself pulling the voltage down.

    Test the charging system and see if it is up to snuff.

    Testing The Charging System - Harley Davidson Community

    Please fill in the year of your bike in the avatar area. I'm assuming it's older than an 03.