Eng Light comes on and have no throttle?

Discussion in 'Electrical' started by trem5150, Jul 24, 2011.

  1. trem5150

    trem5150 Member

    37
    0
    0
    This is a first for me. Bike starts as normal. a block away from the house the eng light illuminates and i have no throttle, just idle mode. guages read good. I checked service manual troubleshooting and I am directed to reference Electrical Manual...any thoughts??????
    thanks
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,305
    153
    373
    Harley Davidson Community have you checked for codes first?
     
  3. trem5150

    trem5150 Member

    37
    0
    0
    on the way
     
  4. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Oh Magic 8 Ball tell me what you see,, The Magic 8 Ball sees a P2101, P2135 or something like that.. :)
     
  5. trem5150

    trem5150 Member

    37
    0
    0
    P0120 TPS1 Range Error
    P1510 EFI Limited Performance Mode
    P1511 Throttle actuator control power management failure of throttle control actuator
    P2135 TPS Correlation Error
    what next???? not sure of the correlation error going to study the serv manual
     
  6. trem5150

    trem5150 Member

    37
    0
    0
    and p/n 32933-08
     
  7. glider

    glider Veteran Member

    25,464
    108
    43
    How does he do that? :lolrolling
     
  8. Jack Klarich

    Jack Klarich Expert Member

    18,305
    153
    373
    Magic Boss It is pure Magic :p
     
  9. Lancer

    Lancer Junior Member

    495
    28
    2
    He's psycho, I mean psychic

    There is a connector on the rear side of the throttle body behind air cleaner. Disconnect it spray with contact cleaner reattach. Should fix the issue.
     
    Last edited by a moderator: Jul 24, 2011
  10. trem5150

    trem5150 Member

    37
    0
    0
    any specific contact cleaner?