Eletrical Problem 2006 Ultra

Discussion in 'Electrical' started by onurb, Jun 30, 2010.

  1. onurb

    onurb New Member

    2
    0
    0
    Every time I push the start button the main fuse blows. No other power problems until I try to start it. Any suggestions?
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Disconnect the Green wire (should be the color) that is going to the starter. Replace the fuse and push the start button.
    Does fuse Blow.

    If No,, the starter solenoid is shorted.
    If yes,,, Remove starter relay from fuse panel, replace fuse and hit start button.
    Does fuse Blow.
    If yes,, check back with post.
    If no, start relay is probably bad, but check with post first.
     
  3. glider

    glider Veteran Member

    25,464
    108
    44
  4. onurb

    onurb New Member

    2
    0
    0
    Just wanted to say thanks. I did what you said and replaced the starter relay and that did it. I think that was the cheapest part I ever bought. Thanks again
     
  5. glider

    glider Veteran Member

    25,464
    108
    44
    Hey Hoop, you saved another soul!:D

    Glad you got it up and running.
     
  6. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Glider, the only thing I don't understand is why does everyone's bike run soooo Good and mine runs like Garbage!:p:D
     
  7. glider

    glider Veteran Member

    25,464
    108
    44
    Well let's look at this situation, what kind of problems do you have? :bigsmiley20:
     
  8. Breeze3at

    Breeze3at Well-Known Member

    4,645
    83
    124
    Good job (again) Hoople! You are the Sherlock Holmes of 'lectricity. :newsmile034:
     
  9. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Are you Kidding? if you cant make your bike run good we are all doomed doomed I tell youLOL:p
     
  10. glenalt

    glenalt Junior Member

    406
    36
    0
    That's like asking why a painters house always needs painting? :D