Electrical?

Discussion in 'Electrical' started by AndyG, Jul 7, 2010.

  1. AndyG

    AndyG New Member

    3
    0
    0
    when i downshift or brake heavy, my headlight dims and speedo goes out. Lasts for about 30 seconds or when i accelerate. Now my taillight and brake light are out. bulb is good. Any suggestions or comments about this problem?
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Welcome to the Forum.. How old is your battery?
     
  3. AndyG

    AndyG New Member

    3
    0
    0
    don't know, was on it when i bought it. about 9000 miles, 2 1/2 years
     
  4. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Well you may want to pull out the battery and load test it. On a '97 your probably a single phase charging system so don't expect much at idle. I therefore would suspect a weak battery/ poor battery cable connections or poor battery ground..

    Once you know your battery is Good, strap a voltmeter across the battery and measure the voltage at idle and at 2500 RPM. Don't believe what you read on the meter until you know the battery is AOK.
     
  5. glider

    glider Veteran Member

    25,464
    108
    44

    Does it have a punch out tag on the battery?
     
  6. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,279
    133
    157
    First thing to do an any problem that has power going off is to ensure the battery cables are secure and clean not just at the battery end but also the other end

    Brian
     
  7. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Best place to start is the source always, Like Hoople said:s
     
  8. AndyG

    AndyG New Member

    3
    0
    0
    Thanks for the input guys