electrical problem

Discussion in 'Sportster Models' started by jmojobiker, Apr 17, 2010.

  1. jmojobiker

    jmojobiker New Member

    My buddy has a 2004 1200 Sportster. He got it at a salvage yard the beginning of last summer - he retitled it and rode all summer after making some minor repairs. Then he garaged it after draining the gas tank. This spring he got it out to start it and the battery was melted. He replace the battery but now this is what it is doing; it turns over but it does not fire up, he says the battery throws sparks like crazy while he tries to start it.

    Any suggestions would be helpful - the brother is on a budget - hence having to go to a salvage yard in the first place.
  2. HarryB737

    HarryB737 Junior Member

    More Info please: When you say "throws sparks like crazy" are you talking about from the terminals, or where? If it's from the terminals that sounds like the terminations are loose. If those are tight, and the cables are in good shape, then that sounds like a major short circuit in the starting circuit IE starter itself or in the solenoid. The other parts of the system are, or should be protected via fuses.

    NEWHD74FAN Experienced Member Retired Moderators

    Jmojobiker, welcome to the HDTalking forum and your first post. I must say your "throws sparks like crazy" comment is rather "scary" as it means serious bad connections or down stream short circuits...NOT a good thing in either case.

    Best to troubleshoot with basics, scraping 'til shiny and coating each with dielectric grease (to inhibit corrosion available at your HD dealer for $10 tube) all the primary wire (ones the diameter of your pinky)...the red and black battery terminals, their respective ends and the heavy starter wire(s) and skinny wire connector end going to the solenoid.

    Don't forget the fuses and relay contacts as well. Now recheck by starting the bike and look for an "uneventful but clean startup"! Sometimes less drama is a very good thing. :newsmile100: