electrical problem

Discussion in 'Softail Models' started by smprfi, Mar 12, 2010.

  1. smprfi

    smprfi New Member

    2
    0
    0
    I have a 2005 night train and replaced the handlebars and when i did i didnt tighten the left side controls down correctly then i washed it and managed to short out the entire left side controls. the headlight, horn and left turnsignal are not working, i found as blown fusa and replaced it but still nothing works, any advice would be helpful.
     
  2. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,630
    68
    99
    Are you sure everything is dried out? Make sure you check ALL your fuses. The wires do not look burnt, right?

    TQ
     
  3. smprfi

    smprfi New Member

    2
    0
    0
    i did it 3 or 4 days ago and its been in the garage so im pretty sure its dry, i checked all the fuses. All the fuses in the box were good, the one that was blown was all by itself and looked to me as if it were in line with the wiring that runs from the controls, i thought for sure that replacing that fuse would fix it but it didnt. Wires look ok, i tested all the wires just in front of the controls and they arent getting power
     
    Last edited by a moderator: Mar 12, 2010
  4. Chopper

    Chopper Senior Member

    1,632
    48
    18
    If the right turn signal woks it can't be a fuse because they both run thru the same power circuit, I think. I would take the left controls off and inspect the wires real good then trace from there back to find the disconect. And go back thru the fuse box real good. Do you know what the bad fuse went to? Do you have a manual showing the wiring?
    [​IMG]
     
  5. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16