Electra Glide Fuel Injection??

Discussion in 'Touring Models' started by BuddyK, Feb 16, 2011.

  1. BuddyK

    BuddyK Member

    46
    16
    0
    I'm looking at maybe buying an '04 Electra Glide Classic with fuel injection. Does anyone know of any problems with the fuel injection on this model and year?
    Thanks in advance for your responses!
     
  2. Chopper

    Chopper Senior Member

    1,632
    48
    18
    Welcome to the forum Buddy, You can't go wrong, it's a smart system
     
  3. montgriz

    montgriz Member

    8
    0
    0
    It's the same Delphi generation EFI used on current models. They've been very reliable, and tuneable if so desired.
     
  4. glen073

    glen073 Active Member

    176
    26
    0
    I have a 2004 Road Glide with almost 105,000 on it now and never one clitch with the fuel injection. I'd say it's very reliable.:newsmile01:
     
  5. lakeforktx

    lakeforktx Active Member

    229
    0
    2
    I have a 04 Elecra Glide Classic and so far I haven't had any trouble out of the fuel system or any other thing... had it for 2 years and 0 problems...knock on wood....:s
     
  6. drbillk

    drbillk Banned

    130
    0
    0
    I have an 04 Ultra... the only issue I have had with the fuel injection has happened twice. Some will say it's not part of the fuel injection; however, it actually is a part. The tube inside the gas tank that goes from the fuel pump to the tank outlet has perforated twice. Never a problem with the actual fuel injection, but you do have to include this part too since you don't have fuel pumps and pressurized tubing inside the tank on carburated bikes.
     
  7. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Funny that the True injector parts (tank pump, injectors, ECM) that were designed and made by Delphi work trouble free but the little hose designed by HD went bad two times. :)

    Even to this day, that hose still is considered something that goes bad. Maybe in 10 more years.....
     
  8. tlyoungb

    tlyoungb Junior Member

    440
    26
    0
    I have an 05 Electra Glide Standard FLHTI. I have 72k on mine, and thus far it have been very stable. I think the 04 has the same EFI system. I believe I was told that mine was a Delphi System.
     
  9. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Just change the filter when its time and RIDE RIDE RIDE:s
     
  10. 03ultra45385

    03ultra45385 Active Member

    146
    28
    3
    the throttle position sensor went bad at about 92,000 on my 03. caused it to run lean.