EJK Gen 3(TFI)

Discussion in 'Dyna Models' started by diver4life, Jul 20, 2010.

  1. diver4life

    diver4life Active Member

    118
    0
    0
    Just got the TFI gen 3 installed on my stock FXD 2010 and let me tell you guys that what a HUGE DIFFERENCE, felt like I was riding another bike. Runs a lot smoother at all rpms just with the settings that came with from the factory. Also want to mention that the installation was really easy and those guys from Dobeck are the best! Thanks Dobecks Performance for a great product! I will be installing the stage 1 in a couple of weeks.:s
     
  2. diver4life

    diver4life Active Member

    118
    0
    0
    Hey Guys sorry if my english is not too good, but I'm from Puerto Rico and still learning english:D I have a question, do I have to do something with the O2 sensors of my bike,or just can leave them as they came from factory?
    Asking cause I read here that some guys removed them and installed plugs instead. Dont know if it makes any difference. Also I have the new TFI or EJK Gen3 and came with 2 extra plastic conectors for O2 sensors but does not explain what to do with them.
    Thanks in advance.
     
  3. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    diver4life; I removed the O2 sensors from the pipes & plugged the ports. NAPA auto stores have the plugs - should be 15mm or 18mm & remember to put either anit-sieze, or HT silicone on the plugs so they seal.

    IRT the connectors - are they extras, or did you not use the ones to plug your O2 wires when disconnected during install? The O2 lead should've connected to the TFI & the hanging O2 wire (runs to disconnected O2 sensor) should have a clip. Of course these aren't needed if you remove them...
     
  4. diver4life

    diver4life Active Member

    118
    0
    0
    Hey Iceman and Steve thanks for the response. I did not do anything with the sensors and I'm confused wright now, I just plugged the TFI Gen3 to the injectors plug and the the ones that was connected to the injectors to the TFI. Dont know where to connect the O2 bypass that came with the EJK. Also are there is any difference with the O2 sensors disconnected?

    I just called Dobecks and spoke with Matt and he explained to me about the O2 sensor bypass. Already installed the bypass thanks for your help .

    Steve, I did the same setup that you did, so far everything working good.
     
    Last edited by a moderator: Jul 21, 2010