Ejk dobeck

Discussion in 'General Harley Davidson Topic' started by BOWHIKER, Jun 8, 2011.

  1. BOWHIKER

    BOWHIKER Junior Member

    434
    28
    4
    I took last week off to get all the little things done that had to be done for my oldest daughters wedding . I had received the EJK from Dobeck and installed it last week . Everything was great except I had 1 concern , the connectors fit fine into my injectors but the piggy back connectors wouldn't go in far enough to snap in to the lock part on the oem connectors , so 1st I wrapped them with electrical tape , after I thought about it I called Chris at Dobeck and he told me some went out that didn't get shaved down for them to connect the way they should so he told me to file them down 10 thousands . It doesn't sound like much but man what a pain ! I started out with just a hand file for about an hour then switched to a gringing wheel in my cordless drill and then back to the file . Finally after about 2 hrs. I was able the get them connected right . I was ready to take everything a part and send it back . I can notice the difference no decel popping , more response , and the exhaust even sounds just a little different . So far I'm happy other then all the hassle to install .
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    It sounds like a lot of work and time to file down the connectors just enough to get them to latch. Did you remember to put the battery in the drill with the grinding wheel? :s

    There was a few of these that went out that needed to be shaved down a bit but they are on top of it now.
     
  3. BOWHIKER

    BOWHIKER Junior Member

    434
    28
    4
    LOL good one Glidder but yes i did have the battery in . Those black connectors are pretty hard , I figured they wouldn't be that tough but believe me they were . Keep in mind I didn't take it back off the bike so room was limited , if I had it may have been a lot easier .
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    I agree there, it's a bit more difficult trying to work in a confined area as opposed to on the bench.
     
  5. purplehazeultra

    purplehazeultra Active Member

    111
    0
    1
    I will keep that in mind. I just ordered mine last week and should be here this week. I can't wait. Hope it comes so I can have it on for this weekend. Heading out to Thunder in the Valley.:bigsmiley8::bigsmiley8::bigsmiley8:
     
  6. MyfirstHarley

    MyfirstHarley Member

    54
    0
    0
    BOWHIKER sorry to hear about all your troubles with the EJK, Purplehazeultra I received mine about 3-4 weeks ago and it installed at the injectors great :bigsmiley11: no problems with any of the 4 connector's, they all snapped and clicked into place nice and tight. I hope your install goes or went well. Tim
     
  7. 09RKC

    09RKC Member

    62
    18
    1
    I received mine 3-4 weeks ago also and wanted to know if I needed to file some before I got started. I called Dobeck and they said there was not a problem with any of the units for the touring models
     
  8. MyfirstHarley

    MyfirstHarley Member

    54
    0
    0
    I probably shouldn't post this as it will show my extreme lack of Harley knowledge I would have thought the injectors were the same or at least the plug ins would have been the same so as not to have so many different part's or styles. Tim
     
  9. blademan

    blademan Active Member

    179
    26
    0

    this is just a guess but maybe the bad connectors were only used on the Softail units because thats what was being assembled when they came in.
     
  10. glider

    glider Veteran Member

    25,464
    108
    44
    I think that the bike plug ins (wiring connectors) are different, not the EJK units but the unit has to have the compatible plugs. This problem arises from the change of plugs from HD, not the EJK.