Ecm

Discussion in 'Sportster Models' started by guam, Oct 26, 2010.

  1. guam

    guam New Member

    2
    0
    0
    Does anyone know why an ECM would go out. The ECM on my 2007 Custom Sportster went out and now I have to replace it. Help.....
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Just curious. Why you think it is bad. Other than it does not work:)
     
  3. dbmg

    dbmg Well-Known Member

    4,617
    48
    21
    I had a ECM go bad at dealer do to replacing fuel tank tech jump fuel pump to drain fuel and burnt ECM out. How positive are you that ECM is bad. If failure was not induced by a fueler added or shorted out from working on bike and failed on its own contact dealer I believe ECM is under a Emission Warrty along with other components. Check owners manual for overview of emission warrty.
     
  4. hogrotten

    hogrotten Junior Member

    621
    26
    0
    Hey Guam out of curiosity where part of the Island are you from? My wife is Chamorro and my daughter is still living there. Also I'd be a little leary of the local dealership. My father in law took his Sportster there because he was having problems with it fouling plugs.They told him the rings were bad,and sold him on getting the work done..... well they might have been bad but it shure didn'tsolve the problem. To this day it's still not right and will foul a set of plugs within 10 min. of relaceing them.
     
  5. guam

    guam New Member

    2
    0
    0
    Wow...thats cool...someone else from Guam in this forum...anyways, im from Yigo..Well to late..i already took my bike to the Harley Dealer and the mechanics were the ones that told me that the problem with my bike was the ECM. The mechanic showed me the original ECM that was on my bike, started it up and the bike was still sputtering, like only one piston was firing...then he got another ECM from another sportster and put it on my bike and my bike worked... My bike is only three years old, has only 1200 miles..i hardly use it...the weather here is so unpredictable..now Harley is charging me $780 for parts and labor...anyways, thanks for the reply.

    ---------------------------------------------------------------------------------------

    Thanks everyone for the reply..anyways this is how it all started..I hardly use my bike..its a 2007, has only 1200 miles..one day it start to sputter and loose power..i thought it was my plugs so i changed it along with the wires...the sputtering stop after i changed them but after taking out for a spin, less than a mile, it started to sputter again and lose power.. then i thought there was probably moisture in the tank so i took it off, emptied it then put new fuel and fuel injector cleaner, thinking the fuel injector was clogged. That didn't work.. So i took it to the Harley Dealer and the mechanic diagnosed it. He told me what he did and it was everything that i did, besides changing the fuel. But nothing worked so he check the ECM, replaced it with another ECM and the bike worked..I just don't understand how it would go out when I hardly use it..I hope this helps all of you.. thank you again...
     
    Last edited by a moderator: Oct 27, 2010