ECM password learn HELP

Discussion in 'Electrical' started by big98, Jun 18, 2012.

  1. big98

    big98 Member

    12
    1
    0
    have been trying to do the password learn on a new ECM for my 2006 Heritage softail but I keep getting the Engine Light (flashing rapidly) .... TSM/TSSM ECM Password Learn Procedure ...
    Then on the last step of the Procedure the emergence lighs will flash 6 times, and when all is done no engine start and get a code u1016, u1255.
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    New as in a blank ecm that was programed by the dealership with the correct firmware, or new as in an ECM that was removed from another bike that was running and is known to be good.
     
  3. big98

    big98 Member

    12
    1
    0
    new Blank

    The ECM is new and has never been on a bike
     
    Last edited by a moderator: Jun 20, 2012
  4. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Was it programmed and loaded with the correct firmware by the dealership.
     
  5. big98

    big98 Member

    12
    1
    0
    I have had this ecm for about 2 years got it new from a dealership never been on my bike, I trying to load the ECM Password Learn Procedure because I'm going on a 4 week around the U.S. its nice to have a spair just in case.

    4 week ride around the country I live in Texas
     
    Last edited by a moderator: Jun 20, 2012
  6. Hoople

    Hoople Account Removed

    7,198
    0
    34
    When dealerships receive ECM's from the factory they are not ready to be installed by the end user. The same blank ecm will connect to many model bikes as long as it has a 36 pin connector. It must also be loaded with the correct firmware and given the correct set of maps for the intended application.

    Where did you get the learn procedure. Are you using the procedure from a 2006 Softail manual.
    Just curious... what's wrong with the original ECM that is already in the bike.
     
  7. big98

    big98 Member

    12
    1
    0
    got the learn from the 2006 Softail manual Just loading a spare doing a road trip soon I have a TSM not a TSSM
     
  8. big98

    big98 Member

    12
    1
    0
    I have done this

    http://www.craigwolford.com/04%20SOFTAIL/se03c.pdf

    and this one

    This text is a slightly modified version of the procedure for the TC88 and V-Rod. I’ve added information to the items that I found confusing, in an attempt to clarify.

    These steps MUST be done EXACTLY as written. Any deviation will result in an unsuccessful transfer of the password and you will need to start step 1.



    1. Set Run switch to the Run position



    2. Turn Ignition key On-Off-On-Off-On-Off-On (this should be done fairly rapidly, no need to wait for the engine light to go off. . . )



    3. Toggle the Left Turn Signal Button twice. (This means PRESS THE BUTTON twice, NOT turn the signal ON AND OFF Twice, which would be four presses.)



    4. Turn Ignition key Off-On quickly. Verify the Check Engine lamp illuminates briefly and then turns off.



    5. Attempt normal start ONE TIME. (This means ONE press of the start button!) Engine starts and stalls immediately. Check to verify that the engine lamp stays on. Password has not been learned.



    6. ECM enters Password Learning mode for 10 minutes. DO NOT cycle the ignition or disrupt power for the entire 10 minute cycle.



    7. Quickly (within 2 seconds) turn Ignition key OFF-ON.



    8. ECM enters Password Learning mode for 10 minutes. DO NOT cycle the ignition or disrupt power for the entire 10 minute cycle.



    9. Quickly (within 2 seconds) turn Ignition key OFF-ON.



    10. ECM enters Password Learning mode for 10 minutes. DO NOT cycle the ignition or disrupt power for the entire 10 minute cycle.



    11. Quickly (within 2 seconds) turn Ignition key OFF-ON. Wait approximately 1 Minute.



    12. Turn Ignition switch OFF. Wait at least 15 seconds. Turn Ignition switch ON and start engine to confirm the Password Learn Procedure is successful. Engine will start and remain running. If engine immediately stalls and fails to restart, the procedure was not successful. Start over at step 1.



    The other thing that SEEMED to be happening was funny oil pressure light behavior, like not lighting when the ignition is turned on!!! Related? Who knows??? Here is what I do know, after running the above procedure three times, turning on the ignition lit the oil pressure light for the first time in 3 tries and the bike fired instantly. I’ll assume I did something wrong in the first two attempts.
     
  9. big98

    big98 Member

    12
    1
    0
    I have done the one from the 2006 softail manual, and also this one
    This text is a slightly modified version of the procedure for the TC88 and V-Rod. I’ve added information to the items that I found confusing, in an attempt to clarify.

    These steps MUST be done EXACTLY as written. Any deviation will result in an unsuccessful transfer of the password and you will need to start step 1.



    1. Set Run switch to the Run position



    2. Turn Ignition key On-Off-On-Off-On-Off-On (this should be done fairly rapidly, no need to wait for the engine light to go off. . . )



    3. Toggle the Left Turn Signal Button twice. (This means PRESS THE BUTTON twice, NOT turn the signal ON AND OFF Twice, which would be four presses.)



    4. Turn Ignition key Off-On quickly. Verify the Check Engine lamp illuminates briefly and then turns off.



    5. Attempt normal start ONE TIME. (This means ONE press of the start button!) Engine starts and stalls immediately. Check to verify that the engine lamp stays on. Password has not been learned.



    6. ECM enters Password Learning mode for 10 minutes. DO NOT cycle the ignition or disrupt power for the entire 10 minute cycle.



    7. Quickly (within 2 seconds) turn Ignition key OFF-ON.



    8. ECM enters Password Learning mode for 10 minutes. DO NOT cycle the ignition or disrupt power for the entire 10 minute cycle.



    9. Quickly (within 2 seconds) turn Ignition key OFF-ON.



    10. ECM enters Password Learning mode for 10 minutes. DO NOT cycle the ignition or disrupt power for the entire 10 minute cycle.



    11. Quickly (within 2 seconds) turn Ignition key OFF-ON. Wait approximately 1 Minute.



    12. Turn Ignition switch OFF. Wait at least 15 seconds. Turn Ignition switch ON and start engine to confirm the Password Learn Procedure is successful. Engine will start and remain running. If engine immediately stalls and fails to restart, the procedure was not successful. Start over at step 1.



    The other thing that SEEMED to be happening was funny oil pressure light behavior, like not lighting when the ignition is turned on!!! Related? Who knows??? Here is what I do know, after running the above procedure three times, turning on the ignition lit the oil pressure light for the first time in 3 tries and the bike fired instantly. I’ll assume I did something wrong in the first two attempts.
     
  10. Hoople

    Hoople Account Removed

    7,198
    0
    34
    That procedure is not correct for a 2006 Softail.