Dyna B2121 & B2137 Error

Discussion in 'Electrical' started by glostick21, Jul 30, 2015.

  1. glostick21

    glostick21 New Member

    4
    0
    0
    My 2012 Dyna Switch Back will not start at all, now. About 4 or so months ago I was getting a hard start only in the morning. With the hard start I would get a V-Error, then it would start up and run with no problems. 5 days ago, it would not start at all. The voltage reg. was warm to the touch, replaced that with a new one. The error codes that I have now I had then. Now all I get a the sound of the starter trying to kick over. I have no idea what it can be at this point. I am getting the following error codes B2121 and B2137. Check for split wires and I was unable to find any.

    :small3d023::small3d023::small3d023:
     

    Attached Files:

  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    B2121 Starter Output Open/BCM Malfunction
    B2122 Starter Output Shorted High
    B2123 Starter Output Shorted Low
    B2124 Starter Output Overloaded
    B2126 Horn Output Open
    B2127 Horn Output Shorted High
    B2128 Horn Output Shorted Low
    B2129 Horn Output Overloaded
    B2131 High Beam Output Open
    B2132 High Beam Output Shorted High
    B2133 High Beam Output Shorted Low
    B2134 High Beam Output Overloaded
    B2136 Low Beam Output Open
    B2137 Low Beam Output Shor
    Here are your codes Start simple by load testing your battery, looks like your low beam light is burned out Do you have any mods on your bike?
     
  3. glostick21

    glostick21 New Member

    4
    0
    0
    That would help if I stated that in the post. I have 4 LED strips lights and LED flashing lights, they have been on and working for the past few years with no problems. In the past month I installed a speaker set, which I have removed once it did not start. Removed the bat. and the main fuse over night and then I tried to start it again and it still does not start. If it helps I do have a Youtube video that lets you hear the should it is making, if that helps.
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Do you have security system? Have you tried a relearn?
     
  5. glostick21

    glostick21 New Member

    4
    0
    0
    I do not have a security system. Just for fun I went back into the diag. and looked at the codes again and tried to clear them. That was no luck. I then removed all my LEDs from the bike and did a diag again and I was able to clear the code. Still was unable to start the bike, but this time the bike seemed to not have enough voltage. Went to store and picked up a new battery. When I got home I put the new battery in and it started right up. Put the LEDs back on and started back up again with no problems. Checked the codes and there was none. Going to take it for a ride once the weather cleans out. Thank you for your help. I hope I can help someone else with this post.

    By the way how would you do a "relearn"?
    :5::5:
     
    Last edited by a moderator: Jul 31, 2015
  6. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399