Done a DTC on my 07 Heritage

Discussion in 'Softail Models' started by Ozzie82, Jul 24, 2011.

  1. Ozzie82

    Ozzie82 Member

    22
    0
    0
    My 07 has a little throttle hesitation in between shifting and seems to use more gas now and so I done a DTC on bike and this was my reading, on the P=none and said pn 34479-07a
    S=none and said pn 68921-07
    SP=none and said pn 67033-046
    T= no r sp
    I understand these are part #'s, any advice is greatly appreciated.
    Thanks.
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    You have no codes. Your clean of codes. You now need to troubleshoot it without the help of any DTC's. You may have an electrical problem but the firmware was not able to catch it.

    Firmware will usually only catch the really bad problems (open wire, shorted wire, completely bad sensor etc). The half-way bad items it may miss.
     
  3. Ozzie82

    Ozzie82 Member

    22
    0
    0
    Thanks for the reply, at least I've got that behind me I think, I read where someone had water in a connection on his map sensor causing something similar to this.
     
  4. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Need more info to really help. Mods done to the engine. Type of fuel enrichment system installed. Miles on bike. Engine performance,,ie pulling a steady incline. Surge at steady throttle? Hard to start when cold or hot.
     
  5. Ozzie82

    Ozzie82 Member

    22
    0
    0
    I don't know how to check o2 sensors etc and such like, I've had the bike for 2 years, my first bike, never rode a Harley until this one and just love it, it had 9000 +- miles on it and I've got 40000 on it now, never had any trouble except tires wearing out, engine performance excellent, still pulls good on steady incline, starts excellent cold, but always hard hot, talked to someone about awhile back and told me that could be on compression when trying to start and learn to bump start, thank you for your time, may have harley to look at it.