Decel backfire on 12 dyna FXDC

Discussion in 'Dyna Models' started by JC1654, Jul 14, 2013.

  1. JC1654

    JC1654 New Member

    2
    0
    0
    I put a Stage one air cleaner & sceaming eagle slip ons on my 12 FXDC and am having severe backfiring on decel.Put in the right program with my Supertuner and no change. Anyone have any idea's?
     
  2. Jack Klarich

    Jack Klarich Guest

    Check for exhaust leaks at mufflers first
     
  3. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,363
    73
    146
    Start bike and cover the end of the exhaust with a towel or rag momentarily and listen for leaks. Repair as needed.
     
  4. dolt

    dolt Senior Member Contributor

    1,889
    83
    237
    As Jack and Bodeen point out, the slip joint between the mufflers and head pipe is most likely the offender. Pull the mufflers and apply some Hi-Temp RTC silicone at that joint, reinstall and tighten clamps. It that doesn't do the job, you will probably need a tune; I have no faith in maps. Best to get her on the dyno and tune.:D
     
  5. kabory

    kabory Active Member

    124
    28
    5
    Had same problem with my 2011 wide glide. I re used the muffler clamps and ended up having to replace them. That's where I found my leak. Was told that clamps are a one time use product
    [​IMG]
     
  6. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    Also, for pipe swap, make sure you have them on far enough past the grooves and "always" run a bead of liquid copper (high-temp silicone) along the inner-edge of pipe for a tight seal. Good luck!