Dangerous engine cut out while riding

Discussion in 'Electrical' started by fairweatherider, Jun 24, 2013.

  1. fairweatherider

    fairweatherider New Member

    2
    0
    0
    My 2008 softail deluxe sometimes decides to cut out while riding. The power goes and the danger begins if you are in traffic. I notice that the engine oil light comes on and I have to turn the ignition off and back on to restart the engine. This has happened several times over the past few years. I was told a couple years ago by a Harley Dealer that it may be the security fob battery so I changed the battery in that but after a few months it happened again. It may not happen for a year and then it'll happen twice in the same day.

    The last time it happened I was turning left at an intersection and it quit, the truck coming at me down the hill had to brake and swerve. This is a dangerous scenario. I read plenty of blogs about this issue but I've yet to read anywhere what the solution is. To add, Harley dealers seem to dismiss that there's a problem and they report having never heard of such a problem. This seems unlikely to me. Please help before I get killed.
     
  2. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Any mods done to bike??? Tuner, air filter etc????? Check the obvious first like the battery cables on both ends. Then has switch housing been changed and possibly a pinched wire. Check for any chaffed wires under seat or loose connection to ecm. Have you check for any faults logged in system??????
     
  3. 03ultra45385

    03ultra45385 Active Member

    146
    28
    3
    I have an 03 Ultra. it had 61,000 miles on it when we got it. It was very consistant about shutting off for an instant at a certain RPM and Throttle position when coming out of a turn with a light throttle. Some times it would do it in lower gears again with light acceration. It finally went away after the dealer reflashed the ECM. Just a thought.
    Good luck
     
  4. Hoople

    Hoople Account Removed

    7,198
    0
    34
    May be a very difficult problem to solve since it happens so infrequently. I agree with dbmg. When & if it happens again, perform a WOW test to see if you logged a DTC code. You may get lucky and have 1 stored. It's a starting point, but unless the problem happened recently, I wouldn't trust what you have stored now.
     
  5. glazier

    glazier Junior Member

    940
    0
    7
    I'd find it hard to believe that it could be the FOB battery. The FOB is only used for starting the bike. Once started, you don't need the FOB until it's time to start it again. Does sound like a dangerous situation thought, and I'd be hesitant to ride it until it's fixed. Good luck.
     
  6. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Hoople is the guy that invented electricity and I follow his wisdom, I would have a look at the main breaker also just because, be sure to let us know what the problem and cure is and best of luck:s
     
  7. wjsjr

    wjsjr Member

    76
    18
    3
    Just to add my 2 cents. I had a similar problem, bike cutting out completely at random times. I don't remember if it threw any codes, but my recollection is that it did not. The problem was finally traced by a competent technician to a faulty bank-angle sensor. I never knew I had one. It shuts the bike off if it detects you've exceeded a certain lean - like falling over. The sensor was faulty and shut the bike off anytime. Replaced the sensor- no more problems. I now keep a spare in my saddle bag. I agree, pretty dangerous condition. Good luck.
     
  8. Slo-Ryd

    Slo-Ryd Junior Member Contributor

    487
    28
    18
    Excellent suggestion wjsjr. The way the BAS is designed to work theoretically lends itself to causing an issue like that if it's faulty. Definitely something to consider and look into.
    [​IMG]
     
  9. biscuit

    biscuit Junior Member

    568
    28
    11

    Wouldn't that(faulty Bank angle sensor) throw out a code?

    Did they test yours electrically or just get 3 guys to lower it to near horizontal with the motor idling?
     
  10. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Not a DTC code but speedo would have displayed the letters "tIP" in the LCD display until he recycled the ignition key. A bad BAS would more likely log a B1135 or B1136 if the accelerometer failed to calibrate but I that would probably not kill the engine.

    More likely a possibility on earlier style MM BAS that used a steel ball. OP's bike uses CAN data to command an engine shut-down so it's probably not a BAS issue (unless OP never looked at speedo display when engine died).