Cutting off at Highway speed

Discussion in 'Engine, Fuel and Exhaust' started by DynaSG07, Jul 20, 2011.

  1. DynaSG07

    DynaSG07 Member

    9
    0
    0
    07 Dyna SuperGlide got it with 460 miles on it last week. It sat. Before i got it, the majority of the fuel system was replaced to include the wire harness and battery.

    Bike has just under 800miles on it. I was riding in traffic this afternoon, but spuddered as i was speeding up. I got worse it seemed as the ride went along. Seemed like it might be injectors or something like the bike was not getting fuel(those were just replaced), well while riding home on the highway at about 80, the bike cuts off, i was in 6th gear, the 6th gear light went out and the bike lost all power, speedo went to zero. about a second later i would say the bike came back on. it did this twice. Any idea's. I'm new to harley but not fuel injected bikes. I am not a greer head at all but willing to learn about the bike before i take it in the shop. I do have extended warranty that has to get transferred from previous owner.(doing that tomorrow)
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    If you lost all electrical power, I would suspect the battery connections. Remove, wire brush and reinstall them and see if that does it.

    Neg off first and on last.
     
  3. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    As Glider stated thats a good place to start. Remember with Fuel Injection battery voltage is critical for proper ECM function. So if connections are loose and reference voltage is erratic so will the bike.....
     
  4. DynaSG07

    DynaSG07 Member

    9
    0
    0
    thanks for the quick reply Glider. I'll look at that tomorrow.
     
  5. bcortani

    bcortani Active Member

    392
    28
    3
    probably wouldn't hurt to drop a bit of seafoam, Marvels or some sta-bil just on the off chance you picked up some bad gas or the remanants of old gas still in lines..