cruise problem 07 ultra

Discussion in 'Touring Models' started by 07electraglideuc, May 9, 2009.

    just wondering if anyone has had a cruisie control wiring problem with 07 ultra. local shop has change module, set resume switch, throttle cables .
    now say it is a wiring issue ? any help would be appreciated.:D
     
  1. glider

    glider Veteran Member

    25,464
    108
    44
  2. not sure will have to ask but i would think so reputable shop and all.
     
  3. glider

    glider Veteran Member

    25,464
    108
    44
    There's a lot of Harley dealers that need some help too. :s
     
  4. hi said it was first thing they tried so i told them anytime the cables or such is messed with you need to do it . they replied ya we know. so will wait and see i guess
     
  5. well now we have a main wiring harness on order? hmmmmmm hope this fixes it am getting a little irratated by this three weeks no bike ,ni:(ce
     
  6. still no word on my bike sure hope this is not normal for harley shops?
     
  7. glider

    glider Veteran Member

    25,464
    108
    44
    What...no loaner bike? :D
     
  8. glider

    glider Veteran Member

    25,464
    108
    44
    BUT...you got a loaner :bigsmiley20:
     
  9. STEVE07

    STEVE07 Well-Known Member Staff Member Super Moderators

    4,034
    68
    42
    Kit. Harley ordered a new harness for Brother-in-law,told us a week.It was there in 2 days. This was 3 weeks ago,I think I would be putting some heat on the dealer