Cruise Control Problem

Discussion in 'Touring Models' started by clanryan, Aug 25, 2011.

  1. clanryan

    clanryan New Member

    2
    0
    0
    Hi - I have a Cruise Control problem on my 02 Road King Classic. It wont disengage CC just by depressing front or rear brake, I have to roll off the throttle at the same time. Also cant roll off the throttle to disengage CC unless pressing a front or rear brake at the same time. It will hold set speed, but if using resume switch to increase speed, speed just gradually keeps increasing, and pressing switch to set wont slow it down either. Just bought the bike privately and it nearly spat me off when trying to disengage CC using the front brake. Brake lights work fine. Any help please?
     
  2. RibEye

    RibEye Junior Member Contributor

    973
    48
    44
    Do you have a schematic for your ride? Cruise control is a fairly straight-forward unit, as far as controlling it is concerned. What you describe sounds like a pinched "set/accel" control line. This is possible in the right handlebar control shell, or somewhere else from there to the cruise control module, possibly under the tank or inside the headlight cowl area. be careful to bias your front brake control in teh slightly "squeezed" state before opening or closing the right handlebar control shell, to protect you front brake switch. It is pretty tiny and fragile. Se your service manul for specifics.

    Get out your schematic and "beep" out all the control lines (using an ohm meter with beep enabled), starting with the "set/accel" control line. On my ride, the cruise control module is under the left side panel.

    Good luck,
    Rich P