Cruise control indicator light blinking

Discussion in 'Touring Models' started by wsw483, Jan 15, 2015.

  1. wsw483

    wsw483 Member

    35
    0
    0
    On my 04 Ultra the indicator light for the cruise control blinks on and off between the red and green colors when the cruise control is in the "OFF" position. When I turn the cruise control on and set it everything works as it should and the light stays on a solid green. It acts like there is a loose wire somewhere but I don't know exactly where to look. This problem only happens when the cruise control is in the off position. The light just kinda flickers between red and green. Any ideas????
     
  2. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    I think I would start with the switch housing on the right side. Check all the wiring to make sure nothing is loose and that there is no corrosion. It may be that the set switch is so worn that it will need to be replaced.
     
  3. tourbox

    tourbox Senior Member

    1,309
    68
    54
    I would lead towards a code. If you have service manual it should tell you how to pull the code/codes for your model. I wou;d check for codes first before going into the wiring.
    tourbox
     
  4. tourbox

    tourbox Senior Member

    1,309
    68
    54
    Correction please. I meant to say " I would lean towards a code" not lead. My bad
    tourbox
     
  5. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  6. wsw483

    wsw483 Member

    35
    0
    0
    No codes showing. As for the "set switch", could all of the cruise control functions still be working if the switch was bad? My cruise works perfectly, it's just that the dang light blinks when going down the road with the cruise off. One thing I forgot to mention is that the light flickers as if there is a loose connection. It is not a steady blink. Could a loose or corroded connection make this happen or would it have to be a switch shorted etc. before the light could get power. It happens even with the cruise control switch in the off position. Thanks in advance for any help or ideas.
     
  7. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Harley Davidson Forums
    Try this
     
  8. stray dog

    stray dog Junior Member

    443
    26
    0
  9. stray dog

    stray dog Junior Member

    443
    26
    0
    "OK I did the check on the diagnostics and this is what came up. 113 122 122 122 111 111 111 112 What is this telling me? I see that the 111 code is good(no codes,memory clear) 122 says the front or rear break was applied but it wasn't. 113 (cruise control switch off) and 112 is (throttle roll off) I got all this information and am not sure what it is telling me. The light still flickers (even sitting in my garage in neutral with the motor running) Again, everything works great but this light flickering thing is driving me crazier!
    Any advice or help would be appreciated. "

    wsw483 wrote above in another thread. I just copied it here to keep it in one thread.

    I think the 122 & 112 are just logged because the cruise was shut off that way sometime in the past and you do not have any problem codes.

    Can you shut down the cruise by turning the switch off? Probably since the green light is flickering and not steady. I'm thinking the switch is starting to short thru to the on position or your getting some stray voltage to that courtesy light from moisture or something. In any of those scenarios you would not throw a code-you can drive all day with the switch on and not use the cruise.
     
  10. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    Like stray dog said....

    Probably the Switch off n on...

    IF you hold the switch OFF with your Pinch-finger does it Stay OFF?

    Try That...

    signed....BUBBIE