Couple of Questions on TFI Install on 2010 FLHTC

Discussion in 'Touring Models' started by SilverGlide, Sep 20, 2010.

  1. SilverGlide

    SilverGlide Member

    7
    11
    0
    Have Read a lot of great information about fuel management systems on this site. I initially intended to get the ECM flashed for Stage I but after reading posts will now go with the TFI. Looks like it runs about $100 more but will be more flexible with add-ons. The install literature says to unplug the O2 sensors but does not mention installing anything in the connectors. Do you have to install any jumpers and does this cause any error codes to be reported?
     
  2. Breeze3at

    Breeze3at Well-Known Member

    4,645
    83
    124
    On my '07 the TFI has connectors that plug into the 02 connector harness. The 02 sensors themselves can be removed and the exhaust plugged, or the wires can be hidden out of sight. Mine appears like the 02 sensors are still in use, but they are not. I think my TFI came with caps for the 02 connectors, but don't remember for sure. Very easy hook up. The hardest part is getting man hands in the small spaces to make connections. The '10's may have different 02 sensor system.
     
  3. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    Yes they come with all the needed things for the install...

    The 02 sensors have to be Un-plugged and a (furnished) Cap plug cover on the Engine side of the 02 wire.

    I also left my 02 sensors in the pipes and just taped the 'loose end wire" back to the "plugged end" so to keep it Like it is in use.... I felt No need to take the 02's out.

    If you want to go back to the Stock Setting and have the bike run Original like it did before. For what ever reason, YOU simply remove the PLUGGED 02 end caps,,,, RE-plug the 02 wire back into the harness, like stock. Take off the Ground connection from the TFI wire at the battery and YOU are back to the STOCK HD setting.... It Will run STOCK as it did BEFORE and it would take LESS than 5 minutes to do so... Reverse to RE-Hook

    That Simple.(.)

    I have a full stage one with TFI and SE 255 cams on my 09FLHR... I could do with out the added parts BUT NOT the TFI...:rofl... What a difference TFI makes.

    signed....BUBBIE
     
  4. fisherman124

    fisherman124 Active Member

    293
    0
    1
    i pulled the tank all the way off for more room ,plus got to clean the heads for the first time on mine gen 3 was 225.00 tax and shipped three day ship with discount from here , if vet u get exra dicount also. tech help they have is great too , good luck
     
  5. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    I called Chris to ask about this and a Change is on the Touring bikes

    He said that the 2010's-11's Touring bikes ONLY , the 02's are Just un-plugged and don't need to have the cap on the engine side for the wire end....

    I would just Tape Together (un-plugged) to keep clean and leave them there.

    signed....BUBBIE

    Call Chris @ TFI Dobecks if you want the Whole story/answer..
     
  6. glen073

    glen073 Active Member

    176
    26
    0
    Mine are unplugged on my 2010 Limited for my PC-V. I just zip tied them up under the side cover. They are still connected to the header pipe.
     
  7. SilverGlide

    SilverGlide Member

    7
    11
    0
    Thanks for the replys. Do you get any error codes reported in the diagnostics with the O2 sensors unplugged?
     
  8. glen073

    glen073 Active Member

    176
    26
    0
    According to Fuel Moto, where I bought my PC-V, it will create an historical code for non op O2 sensors, but will not cause the check engine light to come on.
     
  9. Breeze3at

    Breeze3at Well-Known Member

    4,645
    83
    124
    I just checked for codes on my '07 last week, none show.
     
  10. SilverGlide

    SilverGlide Member

    7
    11
    0
    Appreciate all the info. I had the ECM flashed on my 08 FXDF with SE air and slip-ons and was happy with the results, but didn't like given the MOCO $150 for somethin I couln't see. For now I'm gonna go with SE Air and stock exhaust on the 2010 FLHTC and use the TFI. I kinda like the sound of the stock pipes for the Touring Bike (using the radio) and they dont seem to be that restrictive. Anybody else just done air?