Codes

Discussion in 'Engine, Fuel and Exhaust' started by ahern25, Jul 7, 2012.

  1. ahern25

    ahern25 Active Member

    143
    0
    0
    2004 Fatboy EFI model. 23,000 miles.

    Was on a 200 mile ride today, speeds about 65-80 MPH, about 95 degrees out. Almost home when I noticed the bike began to run rough and misfire. Felt like I was not getting enough fuel. Rode it that way the last 30 miles at about 40 MPH cause it would not want to go any faster. Even at such a low speed it kept wanting to die out and coughing as if it had the ebola virus. Finally got home and checked the codes. P-none, S-none, SP-B1004, B1005, T- No RSP. Question is now that I have the codes. Where do I go from here? I know it has to do with the fuel system but not sure where to start. Any help would be nice. Thanks
     
  2. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,317
    73
    130
    Last edited: Jul 8, 2012
  3. ahern25

    ahern25 Active Member

    143
    0
    0
    No rain, no tach, fuel gauge was fine and moving every time I pumped gas. It was just hot out. Wondering if maybe the engine was to hot and it went into limp mode? Will try it out today and see what she does.
     
  4. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    101
    Check this out:

    Harley Davidson Community

    TQ
     
  5. ahern25

    ahern25 Active Member

    143
    0
    0
    Primed the fuel pump removed the fuse and tried to start the bike. Just a loud pop but did not kick on. Losing fuel pressure some where. Good place to start. No concerned if the hoses are covered under warranty. If not I might have to do it all myself.

    125 dollars later, back to normal. I had a small hole in my fuel line. Went with Harley OEM parts. Looked them up on JP Cycles and could have saved 50 bucks. Live and learn. Bike is running top notch. Thank you to all who responded.
     
    Last edited by a moderator: Jul 8, 2012