Code 32...I think!

Discussion in 'Engine, Fuel and Exhaust' started by chromeInvested, Oct 15, 2008.

  1. chromeInvested

    chromeInvested Member

    23
    11
    0
    I have a 2003 Roadking Injected with 13k on it. I recently installed true duals and put on a PCIII. No problems for 1k and suddenly seems to be running very rich and bogs down/misfires under load. Worse when it is cold. I pulled the plugs and were a little black but I wouldnt consider them fouled. Replaced anyway. I disconnected the PCIII and no improvement.

    I ran the diagnostics and if I did it right I showed a code 32 but only once and not again.

    The service manual covers alot of items that could cause this. Any suggestions on likely culprits before I start replacing a ton of electronics?

    Thanks!
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Check the wiring to the rear injector. Do a wiggle test on the wire with the bike running and see if it makes a difference. Also could be a bad/dirty injector. Before you go crazy throwing parts at it, try some injector cleaner to see if it helps.

    00-03 HD Codes And Activation - Harley Davidson Community
     
  3. chromeInvested

    chromeInvested Member

    23
    11
    0
    Thanks for your suggestions! I tried wiggling the wires but didnt seem to effect the idle. I also sprayed some wd40 around the intake to check for leaks but no change.

    I did throw some fuel system cleaner in two tanks ago because i thought it could be bad gas. Would the injector cleaner work differently? is there a way to pull the injector and clean it manually?
     
  4. chromeInvested

    chromeInvested Member

    23
    11
    0
    ok heres the latest...took it out today and when cold it was blowing blue out of the front pipe and nothing visible out the rear and was running very rough. Warmed up ok but still misfired when under a load. Usually when in 2nd and when I threw in the throttle.

    When I got back there was no code showing. I assume I am checking the codes correctly but when I turn the key for the third time nothing happens and then the engine light comes on after about 10 seconds and stays on for about ten.

    I stopped by the harley dealer and they claim hey will not work on the PCIII bu will check it out if I but a racing tuner for $700!

    Any ideas would be greatly appreciated!