Clutch problem

Discussion in 'Softail Models' started by mv05deluxe, May 10, 2010.

  1. mv05deluxe

    mv05deluxe New Member

    4
    0
    0
    Hello, I have a 2005 deluxe that has only 780 miles on it. I took it out for a ride the other day but didn't get too far as somehow I lost all resistance in the clutch lever and the bike stalled out. I was wondering if this is just a cable adjustment issue or a sign of a bigger problem? could the clutch nut have possibly rattled loose? I did watch the video on the clutch adjustment but I wanted to get some advise before i started just in case its something else.

    Any suggestions or advise would be greatly appreciated.

    Thank you.
     
  2. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    780 miles? not broke in yet.

    Could it be the cable let loose or Broke... any resistance there at all when you squeeze the clutch handle in? or Nothing?
    nothing= a possible broken cable... Start there first IMO


    signed....BUBBIE

    signed....BUBBIE
     
  3. mv05deluxe

    mv05deluxe New Member

    4
    0
    0
    Feels like a little bit of resistance once the lever is pretty close to the handle grip, but not enough to engage the clutch it seems..
     
  4. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    Look at the clutch cable adjustment toward the front frame down tube. There is the adjustment for the cable. Just to See if it has loosened on its own. Roll up or slide the rubber cover to expose the adjuster part.. Does it look tight and Not of come loose(nuts locked and adjustment can't be turned by hand?)

    If okay I would go to the Derby cover and remove it.. checking the workings there.. Like you said ?nut loose and clutch adjustment out. But...

    Should of asked If you were mechanical? and do you have a service manual? before you start here.

    I'll wait for a response first before any further.

    signed....BUBBIE
     
  5. mv05deluxe

    mv05deluxe New Member

    4
    0
    0
    Sorry for the delay in responding...Yes, I do have a manual and I'm am mechanical (or at least think I am)...

    Thanks again for your help and advise..