clutch makin wierd noise

Discussion in 'Sportster Models' started by jerryw618, Sep 7, 2011.

  1. jerryw618

    jerryw618 Member

    60
    6
    0
    hi there my clutch started making a kind of click and whir or grinding sound when i pull the clutch in . just started doing it when i stopped at a light . shifts fine seems to be working ok so far , just concerned about this noise . is it impending trouble ???? also sounds like the starter is running , and bike starts as soon as i switch the power switch (start/stop) on, i dont even have too hit the starter button . , bike did sit in the rain for 2 days .
     
  2. jerryw618

    jerryw618 Member

    60
    6
    0
    seems too be the starter , its running constantly , when i pull in the clutch thats what i hear whining , now if it ever stops raining , ill need to determine if its the switches , relay , water intrusion or something else , anyone else have problems like this ??? ill go do a search see what i can find on this problem . thanks in advance for any advice / help
     
  3. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    I'm no electrical guy put it sounds like your starter is running all the time. Check your switch and starter relay.
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Possible shorted solenoid keeping starter engaged, Check the ring gear for damage:s
     
  5. jerryw618

    jerryw618 Member

    60
    6
    0
    everything seems to be working fine this morning , i went out to work on it , and it starts properly runs fine shifts fine , starter is functioning fine . must have been water in the system , it did sit in the torrential rains for two days . i do appreciate all the help and feedback . ill try to be clearer in future posts . thanks and ride safe