Clicking & Will not start

Discussion in 'Other Service and Maintenance' started by BikBit, Jul 4, 2007.

  1. BikBit

    BikBit New Member

    2
    11
    0
    Uhhg!

    I am a newbie and a dork who needs help after doing something stupid.

    My Husband and I were getting ready to go for a ride and his fork bag was not closed so while sitting on my in gear bike (DUH!) I reached over to close it for him. While stretching to close it I let my hand off the clutch (DUH again!!!). Bike lunged forward and tipped. Now it wont start it just clicks.

    2004 Sportster 883.

    Just call me dumbass!

    Any advice?
     
  2. glider

    glider Veteran Member

    25,464
    108
    43
    Check the kill switch and if that's on, you have to upright the bike and cycle the ignition switch a few times on and off. It's a safety that kills the engine should the bike fall.:11:
     
    Last edited: Jul 4, 2007
  3. glider

    glider Veteran Member

    25,464
    108
    43
    If that don't do it, check the battery connections and possible tighten or remove/clean/replace them and try it. If it is just the solenoid on the starter clicking, chances are that it is the battery connection.
    Quick diagnosis is to hold the start button when it clicks for a few seconds and then feel both the battery terminals and see which one is HOT. If it is a bad connection that one will be the hot one but clean them both with a wire brush so they are clean and shiney and reconnect them.
     
    Last edited: Jul 4, 2007
  4. BikBit

    BikBit New Member

    2
    11
    0
    Glider,

    Thanks for the quick response and tips. Tried the ignition on and off thing a couple of times. Book said to do that too. Battery connections look good and clean. One thing I didn't mention in my original post was that the engine light on the speedometer comes on when ignition and engine are turned on. Can't figure this thing out. My Husband is checking the relay now.
     
  5. glider

    glider Veteran Member

    25,464
    108
    43
    Don't go by the LOOKS of the battery terminals. It could look OK but be a bad connection.

    Do you mean the engine light comes on when it is running?

    That means there is a code set for a fault.
     
  6. glider

    glider Veteran Member

    25,464
    108
    43
  7. pahunter

    pahunter Active Member

    331
    26
    0
    The 04 &up have a tip switch in them. You must turn the key on off on off on to reset the switch Ride Safe Doug