Clicking when i try to start my Road King

Discussion in 'Electrical' started by Raggs, Aug 2, 2013.

  1. Raggs

    Raggs New Member

    1
    0
    0
    I have a 2001 Road King...I tried to jump it off and accidently crossed the cables...The bike still started and I rode all that day... Later that evening I realized that I had no brake lights...The next day I went to start it and I had tail lights but no brake lights, no head lights, no signal lights and my mileage would not show in my speedometer....I also get a clicking in my relays...I gave my battery a charge, replaced my relays and checked to make sure my fuses were ok, but I didn't replace them because they showed to be ok...And im still getting the same thing....Is there a fuse or something somewhere that im missing? Could the starter or ignition be the cause?
     
  2. lorne

    lorne Senior Member

    2,426
    58
    18
    welcome to the forum....what did you use to jump your bike Truck? was the other vehicle running?
     
  3. turnerbend

    turnerbend Active Member

    231
    38
    3
    Could be a bad battery that's not taking a charge. Have the battery checked.....
     
  4. lorne

    lorne Senior Member

    2,426
    58
    18
    yep Darren filled me in on how you helped him with the same problem
     
  5. bikerdad

    bikerdad Junior Member

    415
    38
    9
    My vote is the battery. Crossed wires when jumping it probably caused damage.
    [​IMG]
     
  6. hobo55

    hobo55 Active Member

    306
    26
    1
    Why did you have to jump it to begin with? Sitting a long time, not charging when riding or leave something on?
     
  7. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    Hope you get the electrical gremlins fixed, but jumping a bike w/vehicle isn't a good practice. As you can see, problems will surface...especially when cables are crossed.
     
  8. DFHarley19

    DFHarley19 Active Member

    390
    0
    0
    I am not electrical geek and check on google... I thought anyone who want to learn... it is here
     
  9. seadogbrr

    seadogbrr Member

    42
    0
    1
    If your battery is shot you will get clicking from the starter and may or may not get dash light/head lights. Pull the battery out and either replace it or have a load test. You may find its a simple battery change out to fix your problem.
     
  10. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399