clicking noise when trying to start

Discussion in 'Electrical' started by captbb1958, Jan 23, 2015.

  1. captbb1958

    captbb1958 New Member

    1
    0
    0
    I have a 1988 FXST when I try to start the bike all I get is a click, click, click. If I put cables on to jump, the bike starts right up. I had the battery tested and they said battery was fine. The battery is 2 years old. Any help what to check for would be greatly appreciated
     
  2. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Have the battery properly tested including a load test. Testing voltage with a meter and getting 11.5 or better means static voltage. You need to test the cranking performance which the load test will reveal the true capabilities of battery.

    And be careful jumping battery from another vehicle especially if donor vehicle is running for you are creating a bad situation for the electronics on bike.
     
  3. gator508

    gator508 Senior Member

    2,313
    68
    81
    Follow dbmg's advice here. You should maybe check the battery yourself just to be sure. A fully charged battery should read ~ 12.7. When cranking you should read ~ 14+, if either reading is out of wack and new one is in order.
     
  4. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,602
    103
    296
    Clean and make sure all cable ends are tight.
     
  5. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Check the voltage At the starter when you push the button what do you read?