ck eng lt

Discussion in 'Electrical' started by Cajun Ultra, Dec 8, 2008.

  1. Cajun Ultra

    Cajun Ultra Active Member

    111
    28
    1
    hi i installed a tssm on my 09 ultra and it works, the ck eng lt comes on and then goes off, i start the eng then the ck eng lt comes on again for about 10 sec then goes out ? any help tks glider i used the set up you have on here and its very helpful
     
  2. gs34

    gs34 Junior Member

    639
    28
    5
    When the light comes back on and stays on for 8 seconds, I believe it is an indication that there are faults logged in the system.
    I think you will need to go in and clear the faults. Probably created when you did your install.
    Not a big deal to clear them, the info on how to is in the manual or it's also posted here.
    Do a search and it will bring it up for you.
     
  3. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    101
    Your system is telling you that you have a historic trouble code that was set by the system. The problem is no longer current, because the light goes out. You can check the code following the procedure found on this page:

    Diagnostics and Fuel Injection Related - Harley Davidson Community

    But if you do not do anything, the system will reset after 50 start-stop cycles of 30 seconds or more.

    TQ
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
  5. Cajun Ultra

    Cajun Ultra Active Member

    111
    28
    1
    tks guys i will try that when i get off the boat in 9 days. bye the way i got a 20% off for the system and got a second fob. the dealer didnt even charge me for the dig tech thing for the fobs
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
    Sounds like a good deal and having them program the FOBs to the system is the best way to go.