Check Engine Light

Discussion in 'Electrical' started by 90FXRS, Apr 7, 2013.

  1. 90FXRS

    90FXRS Junior Member Contributor

    419
    28
    6
    I just got a call about a check engine light question. Ole boy has a 2003 Fatboy EFI. When he starts the bike the check engine light comes back on for about 8-10 seconds after it fires up and then goes out. He say he can't get any codes out of it and it runs fine. Any thoughts?

    I won't be back till the later part of next week so this is all of the info I have at this time
     
  2. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,631
    68
    99
  3. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    If he wants it OFF and Reset. I'd take it to a small Non HD shop and see if $20 Bucks would do the Honors.

    I did this long ago on one of my bikes and the mechanic said "On the House"...
    I gave him 10$ for a beer and burger. Both Happy.:D

    signed....BUBBIE
     
  4. pully

    pully New Member

    1
    0
    0
    I had the same problem on my '09 Fat Bob. Check light would come back on for a few secs after i'd started it but the bike was running fine, for awhile. Then it started cutting out and the engine check light would come on and go off twice before i could start it again. Turned out to be a very slightly (and i mean VERY SLIGHTLY) bad connection on the system relay. Real pain to find and get at. When the relay was plugged in it was partly pushing one of the connectors out the back. Might be worth a look.
     
  5. 90FXRS

    90FXRS Junior Member Contributor

    419
    28
    6
    Thanks for the input. I'll be back on Friday and after I look at it I'll let everyone know what I find.
     
  6. Hoople

    Hoople Account Removed

    7,198
    0
    34
    This is right out of a 2003 HD EFI manual. It may work.
     

    Attached Files:

  7. pigrider

    pigrider Active Member

    110
    26
    0
    Just a thought here, mine does the same thing if I let it sit long enough over the winter for the battery to go about dead, once I get the battery off life support everything is back to normal.
     
  8. 90FXRS

    90FXRS Junior Member Contributor

    419
    28
    6
    He had a system relay error. Looked at the rely and socket and it appears that a pin was not making contact very well. Finally got to the backside of things and checked the pins. Sure enough, one of them was not inserted into the slot all the way. Makes me wonder if someone has been into this before. He's the second owner.
     
  9. maddhatter

    maddhatter New Member

    1
    0
    0
    Would having a engine light on an the light not NOT giving any codes be caused by this ?

    If there is no codes what else would cause the light to come on ?
     
    Last edited by a moderator: Dec 2, 2014