Check Engine Light ?

Discussion in 'Touring Models' started by Slightly Dazed, May 1, 2009.

  1. Slightly Dazed

    Slightly Dazed Member

    11
    11
    0
    I have a 08 Ultra Classic, never had a problem. I was out for a ride and hit and pot hole tat gave the bike a good shot. The check engine light came on for about 5-6 seconds then when out. Bike ran fine and felt normal for the rest of the ride. Now ever time I start her up the light come back on for a 5-6 seconds then goes out, no codes shown, bike runs fine. Anyone had this problem? Is there anything I can try or should I take it in to the dealer?
    Thanks for any help.
     
  2. RD King

    RD King Member

    24
    11
    0
    First check your battery connections to make sure they are tight.
     
  3. Slightly Dazed

    Slightly Dazed Member

    11
    11
    0
    I have check that and about everything else I can get my hands on
     
  4. RD King

    RD King Member

    24
    11
    0
  5. gs34

    gs34 Junior Member

    639
    28
    5
    The light coming on after start, staying on for a brief period, then going out, is the indication of an inactive fault code stored in the history log.
    You need to check your DTC Log and see what the code was, then you can either clear it, or if it does not reoccur, it will clear itself after 50 starts.
    See here: 09-08-07 DTC Codes - Harley Davidson Community
    Oh, and do yourself a favor and buy a shop manual. It will be the best money you spend on your ride.
     
    Last edited: May 1, 2009
  6. glider

    glider Veteran Member

    25,464
    108
    44
    Good deal GS, look at #8 in that post to clear the code after logging it.