Carb Problems STILL

Discussion in 'Dyna Models' started by Moe DIgger, Apr 24, 2008.

  1. Moe DIgger

    Moe DIgger Member

    15
    11
    0
    HHI All. Last post was the same problem. rough idle backfire, rough mid range.

    I took the advise I got here and cleaned out all the jets. CHecked the float. the accellerator pump diaghpram had some cracks on it, so I rebuilt that. The enrichner looked worn so I put in a new one. New float bowl gasket. new oring carb to manifold. Before I did any of this I checked the intake and carb for leaks with carb cleaner while it was runing. did not find a problem.

    Put it all back together tonight. Same friggin problem almost. Ran smooth mid range. Ran poor with the enrichner pulled all the way out???? Ran smooth woth it pushed in???

    HELP. I am just baffled. even tho I think I know what I'm doing. HAHHH

    If I don't get this thing fixed in the next couple of tries>>> I gonna just go buy a mukkuni. HAH

    Any and all advise is appreciated...

    MOE
     
    Last edited by a moderator: Apr 25, 2008
  2. glider

    glider Veteran Member

    25,464
    108
    44
    It should run poorly with the enricher pulled all the way out with any heat in the engine. It still sounds as if the float or needle & seat are causing the problem with too much gas.
    How are your plugs and possibly wires. It could also be an ignition problem under load breaking up from what you say.
     
  3. Moe DIgger

    Moe DIgger Member

    15
    11
    0
    YEah thanks so is that why gas is leaking out of the bottom of the carb? Can't really tell where it's coming from.
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    About the only thing that causes gas to overflow the carb is debris like rust etc in the needle & seat or a defective needle/seat assembly
     
  5. Moe DIgger

    Moe DIgger Member

    15
    11
    0
    Thanks. What about the float? The only thing I haven't done is take the float off and look at/clean the needle and seat. SO does HD have a float KIt? New float with needle etc?

    Preciate your help....

    MOE
     
  6. Moe DIgger

    Moe DIgger Member

    15
    11
    0

    ALso I did the measuirment thing per the manual... 15 to 20 Degrees. 7/16. I notice tho the float does not seem to just drop freely. Like fast. It seems to be binding even tho it does drop all the way down it's just not instantaneous>>> HMMMM
     
  7. glider

    glider Veteran Member

    25,464
    108
    44
    Have to look into why it is binding, the dealer can probably order parts or online you can find a float assembly for the CV carb.
     
  8. Moe DIgger

    Moe DIgger Member

    15
    11
    0
    Hey! I just wanted to pass along a BIG thanks a BUNCH!!. For helping me with this problem.

    I got it DONE yesterday. Funny, one dealer had the float and another had the needle. I had to make a 40 mile round trip. SO when I put them In The float was not binding at all. I adjusted the float per the manual. I also rebuilt the accellerator pump. While I had it apart I figured?? Bettr take a look. The diaghphram had cracks in it. It looked like it had been sitting out in the sun and got dried out.

    It now runs like the Monster it has always been.

    Thanks again for your help. COuld not have done it with out you!

    MOE D
     
  9. R. Lewis

    R. Lewis Senior Member Retired Moderators

    2,183
    48
    5

    WAY TO GO !!!! On your way to doing repairs in your sleep!!!!! :bigsmiley8:
     
  10. glider

    glider Veteran Member

    25,464
    108
    44
    Hey Moe, glad you got it running right. They can be a problem sometimes but with enough perseverance, you can usually get it going again.