can some tell me what else to check charging problem

Discussion in 'New Member Introduction' started by Jon Berndlmaier, Sep 5, 2016.

  1. Jon Berndlmaier

    Jon Berndlmaier New Member

    2
    3
    2
    I have a 05 wide glide and I installed a new battery, new battery cables, stater, rotor, regulator, still not charging, tested the stater and rotor, all came up good, put in a new 1.4 kw starter, tested all the test you can do for the stater and they all passed, tested the diode,s on the old regulator and the new one, they come up good. the 40 amp fuse is good. I ordered another regulator just in case the other new one is bad.
    I am going to test the leads from the battery side plug from the regulator and do a few more test on the regulator if I find out what it is I will post it up.
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  3. Jon Berndlmaier

    Jon Berndlmaier New Member

    2
    3
    2
    thank you very much I will do those test today if I get a chance.
    keep on riding

    I did your test, using the test light I got nothing on the 3 pin connector, but using the volt meter at the highest setting I did get voltage
    there for with all the test that I did on the stator and the leads, the regulator is bad and I already ordered a new one, now I can send the other new one back with the knowledge knowing that their regulator is bad.
    Again thank you very much for your help.
    keep riding and keep it off the ground
     
    Last edited by a moderator: Sep 7, 2016
    Jack Klarich and HDDon like this.
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Good on you, HD has had alot of problems with off shore regulators, now you know the final test