can anyone help with this

Discussion in 'Touring Models' started by badge171, Sep 16, 2010.

  1. badge171

    badge171 Member

    31
    16
    0
    Hello all
    I have an 09 street glide ,love the bike ,I believe it has the auto primary adjuster, problem is when slowing down the bike and steady low rpm I can hear the chain almost sounds like its hitting or moving the adjuster up and down. when I increase RPM or pull clutch noise goes away, sure its coming from primary, I know I shouldn't but cant lug the bike at slow speeds because of the noise, any suggestions , thanks
     
  2. softailhog

    softailhog Active Member

    287
    18
    1
  3. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    Some times the Auto Adjuster NEEDS a little help... If you ride the bike up to about 40 miles per hour (this is MY way) in 3 rd gear apply the brakes firmly to slow down quickly, dragging down the rpm..... (keep the throttle-engine pulling) while ON the brakes..... Then repeat again about 2 more times and the slack should be adjusted out....

    signed....BUBBIE

    Glider has this a little different (his way) in the self help section..
     
  4. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Had a noise in my 2008 Electra. Tryed this method and bike is very enjoyable to ride. I have herad of a guy that when the dealer removed primary cover the chain was rubbing inside cover of inner primary cover. His bike was a 2008 King.
     
  5. hogrotten

    hogrotten Junior Member

    636
    28
    2
    What are your down shifting habbits? I usually catch the next lower gear at about 1800 rpm when slowing to a stop, makes for nice smooth downshift with no need to "blip" the throttle.
     
    Last edited: Sep 16, 2010
  6. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    RE-reading above: IF under 2 YR warrantee and NO extended.... Take It Back to dealer to see IF there May Be a Problem with the Auto-adjuster that Might need to get fixed.

    signed....BUBBIE
     
  7. badge171

    badge171 Member

    31
    16
    0
    thank you

    Just wanted to say thanks much, adjusted as you instructed after bike was good and warm, took the noise completely out, had me bothered for awhile. you all fixed me up thanks again
     
    Last edited by a moderator: Sep 21, 2010
  8. ballpeen

    ballpeen Active Member

    172
    18
    1
    Gotta love it,, so many here with a lot of knowledge to share,, best forum anywhere... Ride Safe.. Tim
     
  9. lowriderfrf

    lowriderfrf Member

    57
    18
    1
    Anyone know if this method of setting an auto adjuster works on a '06 Dyna Lowrider (six speed)?
     
  10. Breeze3at

    Breeze3at Well-Known Member

    4,645
    83
    124
    I think '07 was the first year the automatic primary adjuster was used. Earlier years had to be manually adjusted through the inspection cover in the middle of the primary cover. There are also a few companies (Hayden is one) that make auto adjusters that retrofit. I've had one on my '92 for 15+ years.