Buzzing sound then engine died

Discussion in 'Touring Models' started by roadking01, Jun 15, 2010.

  1. roadking01

    roadking01 Member Contributor

    97
    6
    0
    Coming home from work yesterday, I heard a faint buzzing sound coming from the front of the bike, after a few minutes after I heard the buzzing the engine just died I was going about 40 mph and I didn't fill any hesitation before it died, I tried to start the bike but all I got was some sputtering and then nothing.

    I checked for codes and have a 41 crank possition sensor code, however I have about 2k miles on a brand new one. I have spark and I spayed starting fluid in the throutle body and the engine turns on for a couple of seconds so I think my problem might be lack of fuel? can a bad crankshaft possition sensor cut off fuel supply? could the buzzing sound be from the fuel pump going bad? any suggestions?

    The bike is a 01 RK with 130k kiles on it everything stock exept for slip on mufflers and as far as I know the fuel pump has never been replaced.
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    I don't know if your model year does it but I know my 2009 will. If the crank sensor signal is interrupted the system relay opens and kills both fuel and spark.

    It would be Great to know what your fuel pump pressure was.. That would tell you a bunch, but without the special adapter it is not easy to take a reading.
     
  3. futurerider

    futurerider Active Member

    252
    38
    2
    The bike is a 01 RK with 130k kiles

    OMG is that a type-o?
     
  4. R. Lewis

    R. Lewis Senior Member Retired Moderators

    2,183
    48
    5
    ? - Kilometers maybe ?
     
  5. kemo

    kemo R.I.P

    1,690
    48
    5
    Is the buzzing coming from around the fuel tank, I wonder if your fuel pump is defective.
    kemo
     
  6. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    Do you hear the fuel pump running
     
  7. glider

    glider Veteran Member

    25,464
    108
    44
  8. roadking01

    roadking01 Member Contributor

    97
    6
    0
    not a typo 130,000 miles.
     
  9. roadking01

    roadking01 Member Contributor

    97
    6
    0
    I opened the tank and I can hear the pump presurizing.

    I can also see a some bubbles not a lot coming from the bottom of the pump when I turn on the pump is presurizing
     
  10. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Bingo! Bubbles are bad. :p