Broken push rod

Discussion in 'Engine, Fuel and Exhaust' started by rosankyharleyman, Jul 12, 2008.

  1. Took a little ride today and after about 50 miles we stopped and I noticed oil on the right side of my bike. The front cylinder intake push rod tube seemed to be a little crooked. After taking the push rod tube off I found the push rod bent and almost broke in half. It was like it had been cut with a hack saw half way thru. I have a big bore kit and screaming eagle heads with an Andrews t 26 cam. Also have almost a thousand miles since the big bore kit and head installation. I also have the screaming ealgle adj push rods. Anyone had any problem with these? I dont think I had any valve and piston contact, at least it does not run like it. It just seems like the push rod started splitting in half. Really puzzles me. Any thoughts?
  2. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    Shocked that is wasn't running like absolute crap! Did you replace the pushrod already? How does it run?

    When you had the upgrade done, did you have heavier springs put in? If so, do you need a stouter pushrod?

  3. Yes, I replaced the push rod and it runs fine. The heads do have stouter valve springs but the s/e push rods should work fine.

    I am running flat top pistons with s/e cnc heads, is it possible to have valve contact without bending the valve??????
  4. The Bad Man's Angel

    The Bad Man's Angel Active Member

    get rid of the SE adj push-rods and replace them with JIMS push-rods.
    Never seen this with a little cam like the 26 but fairly common with bigger cams.