broken front engine motor mount

Discussion in 'Touring Models' started by lqdesertrider, Aug 21, 2009.

  1. lqdesertrider

    lqdesertrider Member

    54
    16
    0
    25K on 2004 road glide still under extended warranty.

    I was experiencing excessive vibration and took it into dealer and they said I had a broken front motor mount. Couple of ?s is this unusual?, are there other things I should have the dealer check which could be related to this?

    thanks,
     
  2. smkinnan

    smkinnan Active Member

    121
    18
    1
    How does it run after the mount was replaced?
     
  3. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    101
    Not unheard of. There were problems with some of the motor mounts, so HD had a Tech. Serv. Bulletin on changing these out. Not sure if it was gratis or not. But sounds like yours was covered under extended. With the new one just installed, you should not have to worry about this issue. BTW, make sure you do not let oil flow onto the motor mount if you are doing your own oil changes. That will impact the life of the mount.

    Improved Rubber Motor Mount - Harley Davidson Community

    TQ
     
  4. IndyRoadKing

    IndyRoadKing Member

    11
    11
    0
    It is a know problem on 2006 and older models. Here is a link to SB from 2005

    Motor Mount SB
     
  5. lqdesertrider

    lqdesertrider Member

    54
    16
    0
    Thanks for the info. I bike my bike up tommorow and I will see how it rides.
     
  6. STEVE07

    STEVE07 Well-Known Member Staff Member Super Moderators

    4,034
    68
    43
    Some people also end up with torn front mounts because the proper care wasn't taken during oil changes and the old oil spilled onto the mount from removing the filter,then not cleaned off completely and the mount becomes soft and tears easily:s
     
  7. dolt

    dolt Senior Member Contributor

    1,815
    83
    206
    '02 FLHT service manual recommends replacement at 25k-35K miles. I know, there are original mounts with 75K miles on them and they have never been checked or re-torqued, just passing on what the SM recommends.