Brake light help

Discussion in 'Sportster Models' started by bikecurious, Jan 12, 2011.

  1. bikecurious

    bikecurious Member

    47
    0
    0
    Hello all,
    So Earlier today I realized my back brake was not lighting up my brake light. then I rode about 30 miles and now my front wont light it either.
    My running light is just fine.
    I removed the lens and took a look at the bulb.
    the inside wire,(obviously my brake light) was not broken but also didnot light up like the outside wire....
    Any advice? I need her fixed asap...she's my only form !
    :bigsmiley30:
     
  2. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Check the plugs in the tail light housing, I have seen water level halfway up and the lamps were still working...!

    http://www.hdtalking.com/electrical_and_lighting_systems/11107-tail_light_wiring.html

    I would also look into the condition of the stop switch in line with the brake hose for the rear (common for them to fail), check out post #14 by Hoople...

    http://www.hdtalking.com/touring_models/34751-rear_brake_light_switch.html#post328656

    And for the front stop switch plunger type near the master cylinder/lever. Do use a penny or shim to space the lever out and prevent damaging the plunger nib.
     
    Last edited: Jan 12, 2011
  3. zeejay1970

    zeejay1970 Member

    6
    0
    0
    turn the ignition on and pull the brake lever in. Do you hear a click when u do this? If no sound its your brake switch, Easy to replace right above right passenger foot peg on the frame
     
  4. Breeze3at

    Breeze3at Well-Known Member

    4,643
    83
    123
    I would try another bulb before going further. Even though the wire looks intact, the bulb could be bad.
    Then start trouble shooting the cause.
     
  5. karlsbike

    karlsbike Active Member

    264
    0
    3
    Or just hook up a VOM and have someone apply each brake lever (or use a tie-wrap to hold it engaged)
     
  6. Brutal FXDX

    Brutal FXDX Active Member

    155
    28
    2
    Or maybe the Brake light is staying on, meaning the the brake switch in the rt switch housing is broken?? Just a thought. I see it often.
     
  7. bikecurious

    bikecurious Member

    47
    0
    0
    Hey!
    Thanks for all the advice! So I ended up replacing the bulb and the entire plug.
    Now the front works, but the back still does not engage the light. Would this mean the rear switch is done for? i dunno, i kinda like it this way, I can brake while also flashing my light to attract attention from cagers behind me....but in the long term I should probably fix it haha
     
  8. Brutal FXDX

    Brutal FXDX Active Member

    155
    28
    2
    Yeah your rear brake switch as most likely failed.I see it too often. To make sure unplug the two wires from the switch. Turn the ign on and touch the 2 wires together. If the brake light illuminates the switch is bad and needs replaced.