bike stalls then takes off

Discussion in 'Touring Models' started by hkhajah, Apr 16, 2010.

  1. hkhajah

    hkhajah Member

    50
    16
    0
    hello,
    I have a 2005 screaming eagle with a 103ci engine, i changed the pistons to a screaming eagle 10.05 dome piston, installed the 51 zapper throttle body and a baker 6 gear, bike was runing fine until i came bake from a trip last november covering 2000km , the bike would kind have this cut as im driving steady, the dealer changed the throttel sensor and said it from it , they then upgraded my ECM, i normaly have a PWC3 installed so it doesnt matter, but sine that time , when im driving 80 km and rpm is below 3500 and i give it full throttle, the bike back fires with wierd sounds and it feels like its being pulled back, after rpm reaches 3500 it then takes off....
    pls note that this was after i put the bike on DYNO test as it was worst before.....
    Does any one have any idea?? its driving me crazy...:worthy
     
  2. maine-e-axe

    maine-e-axe Junior Member

    732
    28
    1
    Sounds like something to do the the timing advance which is controled by the ECM I think.
     
  3. glider

    glider Veteran Member

    25,464
    108
    44
  4. hkhajah

    hkhajah Member

    50
    16
    0

    this sounds interesting !! so it has to be tested at the dealer.
    The thing is at the Dyno , they told me its getting in more air than fuel..

    Maine... i have a Power commander installed, wont that over ride the ECM ?
     
    Last edited by a moderator: Apr 16, 2010
  5. hkhajah

    hkhajah Member

    50
    16
    0
    i went to the dealer and they reset the TPS.... i also changed the crank sensor as it gave an error.
    I tried the bike and again as i drove 60km on 3rd gear and then gave it full throtle it didnt take off like it should do, its like some one pulling me back. As i slowly lifted the throttle back it then took offf.... what should i do ?? should i replace the ecm for a new one ?