Bike sputters or spits but does not die

Discussion in 'Engine, Fuel and Exhaust' started by sincityharley, Oct 9, 2010.

  1. sincityharley

    sincityharley Member

    33
    16
    0
    I'm having a problem with my bike sputtering for lack of a better word. Its not a constant sputtering. Also it takes 4 starts exactly after not riding for awhile before it starts. After its been running for a bit it will start up first time every time. You can hear the fuel pump loading up the fuel each time. It seems to happen mostly at low speeds. I cant recall a time it ever happened on the freeway at speed. It never dies though. I replaced the spark plugs and the wires. I would like to pressure test the fuel but I don't want to spend a bunch of money on a tool for one time use. Are there any tricks for checking fuel pressure? This sputtering happens on a full tank as well as a low tank. Any advice out there? I ride an 02 EFI Heritage Softail. Also is there a way to test the fuel injectors?
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  3. RibEye

    RibEye Junior Member Contributor

    973
    48
    45
    Rub hole in one of your fuel lines inside your tank. Fuel pressure to the injectors is a likely issue.

    Enjoy,
    Rich P
     
  4. Wayne R

    Wayne R Active Member

    228
    26
    0
    I just had a problem with my bike sputtering and spitting intermittently, I was advised by a Harley mechanic the problem sounded like a intake manifold leak, you dont say how many miles are on your bike, but I have just over 50k and was told its not uncommon for the intake manifold gaskets to go bad at these mileages, I would also research the self help section here they explain how to check for vacuum leaks.

    I just had a thought and don't know if this is a reccommended way of checking fuel pressure but I can tell you for fact you'll know if the bike is pumping fuel, after I installed the intake manifold gaskets on my bike I put everything back together and checked all connections I turned on the ignition, then pressed the run button switch heard the fuel pump kick in and out pumped a bunch of fuel don't know what the pressure was but can tell you there was plenty, I had pushed the fuel line in but apparently it had not clicked and locked, what I'm saying is to disconnect the fuel line at the fuel injectors real easy to do but first you have to release the fuel pressure or gas will come splashing out at you if in fact there is fuel pressure present, pull the fuse for the fuel pump and start the bike and let it run until it stops then put the fuse back in and go to the efi module and click the button on the fuel line and release it turn the ignition on and press the run button, don't press the start button you will know right away if you have fuel pressure gas will pump out for a second or so through the fuel line this won't tell you the pressure but you'll know if there's enough, the repair manual will tell you to drain the fuel tank and run the bike dry to remove fuel pressure, but if you go to the self help section on this forum you will find an what I just wrote and instructions on disconnecting the fuel line also make sure you don't disconnect the fuel line at the tank may leak on re-installation
     
    Last edited by a moderator: Oct 10, 2010