bike runs for 2 minutes then stops

Discussion in 'Softail Models' started by tramp, May 1, 2013.

  1. tramp

    tramp Member

    6
    0
    0
    Hello, I have a 1993 flstn she starts fine but after a few minutes stops. If I try cranking she will not re-start until I turn off the ignition switch and then turn it back on and then she will run for a few minutes and stop again.Hope someone out there can help:(
     
  2. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,316
    73
    130
    Do you still have power to lights etc. after it stops?
     
  3. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    With the ignition on check with volt meter or test light at the coil for power, bet you have a break in the wire from the cam cover to the coil or a bad ignition switch
     
  4. SledDog

    SledDog Senior Member Staff Member Moderator

    1,852
    58
    42
    Are you getting fuel? Slow fuel flow could do this. A bad cam position sensor will also.

    More info for the symptoms will help us help you.
     
  5. tramp

    tramp Member

    6
    0
    0
    Thanks, I will check these things out when I get home Friday
     
  6. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Once the bike starts loosen the gas cap. It might not be venting properly.
     
  7. tramp

    tramp Member

    6
    0
    0
    Getting fuel, lights are fine. When bike stops if I do not turn ignition switch off there is no spark, once I turn ignition off and then back on everything is fine for about 2 minutes. Lights do not dim they stay bright when bike stops.
     
  8. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Check the wiring coming out of the nose cone to the coil, is the wiring intact no signs of over heating, some times the pick up in the cone gets over heated and can cause a problem like this, you can also try removing the cover and get more air in there to verify this