Bike just shuts down at 90mph

Discussion in 'Touring Models' started by spartacus55, Mar 18, 2010.

  1. spartacus55

    spartacus55 Active Member

    113
    26
    0
    Was motoring up the hi-way pushing it up to about 95 mph when all of a sudden the engine cutout Ithought i had run out of gas but my idiot light did'nt come on yet i was in the fast lane with traffic coming up rapidly behind me and i found myself having to cross about five lanes of traffic to get to the shoulder not exactly fun during rush over traffic and not one cager gave me a brake i made it over three lanes when i downshifted and boom the engine started back up. I just had new bars and all the cables replaced anyone have a similar proiblem
     
  2. Safehaven

    Safehaven Active Member

    351
    16
    1
    Long shot but maybe air in the fuel line?

    No other things you've noticed? I'm sure there are tons of things you can check, but I've only had that happening when driving a car, I didn't bleed the fuel line correctly and the first time I gave it the beans, the trapped air went into the injectors and misfired / stalled. Off course I pulled the clutch, but like yourself, as soon as I let go of it on the shoulder while still in motion it came back to life..

    sure glad you made it out unharmed.

    Take care,
     
  3. spartacus55

    spartacus55 Active Member

    113
    26
    0
    Thanks for the help safe after the restart it ran perfect iguess it could be an air bubble but i'm still concerned it could be something else like a rev limiter malfunction well i'm having cruise installed next week maybe they can find something then thanx again
     
  4. Slapp

    Slapp Junior Member

    458
    28
    3
    Not sure if this will help but bring it back up to the speed again and see if it shuts down again. It may be a max speed sensor built in to the system, shuts it down at a certain speed. Had a truck that would do that. It is just like the cruise control on my bike cannot set it over 85 mph. If the bike is completely stock that could be the problem, "THE MANS" way of keeping control of the people (LOL).
    This is all just food for thought.
     
  5. Breeze3at

    Breeze3at Well-Known Member

    4,645
    83
    124
    Often the last thing worked on is the culprit for a problem. I'd carefully check all the wiring (esp. on/off switch) on those new bars. There were a LOT of wires/connections involved in that change. One marginal connection would do it.
     
  6. sharpscuba

    sharpscuba Banned

    945
    0
    1
    First thing I would look at is going 95 in rush hour traffic in Jersey!
     
  7. hoggy25

    hoggy25 Active Member

    127
    26
    0
    Maybe you have an automatic ticket saver mode. Kidding of course. But it might be circuit breaker that heated a bit to open the circuit than reset when it cooled. Just a uneducated guess.
     
  8. maine-e-axe

    maine-e-axe Junior Member

    732
    28
    1
    I had the same thing happen to me, it was the fuel filter pluged up, only did it at WOT.:s
     
  9. relxn88

    relxn88 Member

    37
    16
    0
    This is just my 2cents, but the most recent change(handlebars) is where I'd look. Could be the kill switch shorting out or maybe a wire is broke and moves. I'd open up the awitch housings and look at the kill switch and wires. Doesn't take much to break the solder joint on the kill switch.
     
  10. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Could be as Smitty says, you are hitting the rev limiter in lower gear. It could also be fuel starvation, air in the fuel line (the dreaded tiny holes in the fuel lines), clogged inlet filter (water or debris from last fill up), overheating (real that the rear cylinder is cutting out) or false (bad temperature sensor), or some electronic failure (is there a key symbol illuminated indicating diagnostic codes were thrown)? Plenty of possiblities and finally is the bike under warranty that you should at least alert the dealer that you had the problem to see if there are service bulletins pending?