battery disconect and mapping

Discussion in 'Electrical' started by bamacfa, Jun 12, 2010.

  1. bamacfa

    bamacfa Member

    55
    6
    0
    I dissconnected my battery the other day and ever since then the bike has run differently. It is backfiring much more and has idiled much slower than usual it has even shut off once at a stop. Can disconnecting the battery mess up the mapping? thanks in advance
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Mapping as in look up tables that are in the Factory ECM, the answer is no.
     
  3. bamacfa

    bamacfa Member

    55
    6
    0
    Thanks so much guys I will check to see if the battery in the ecm failed.
     
  4. bamacfa

    bamacfa Member

    55
    6
    0
    Well here is an update. Took it to a friend and he checked everything out and it seemed to be in good working order. he asked when I had changed the plugs and I had done this about 6 months ago. He replaced them just to be safe and it fixed the problem no more backfires and better acceleration was restored. I wouldnt have thought the plugs would have gone bad so quick
     
  5. glider

    glider Veteran Member

    25,464
    108
    44
    I've had numerous parts that were bad and were new too. Never assume that because it's a new part that it is good until you know better. It saves a lot of aggravation.
     
  6. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Had new plugs with no threads LOL:D
     
  7. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Champions, I took them back to Napa, They gave me 2 more and a refund:D