BANG goes the bike . . .

Discussion in 'Softail Models' started by 2manycats, May 30, 2014.

  1. 2manycats

    2manycats Member

    15
    0
    0
    I need some opinions on what this might be from those who are much more experienced than this newbie. Today I was on the highway, 65mph-6th gear on my 2010 FLSTC. A hellacious BANG came from somewhere below my butt, the bike shut off, and I drifted to the berm. Just because I figured I had nothing to lose, I tried to start it-nothing, I have power, but the bike won't turn over.

    I tried going through the gears, and-there are no gears. I worked the shift lever through all the gears from 1-6, and I can push the bike when it's been put in gear. In other words, no matter what gear its in, the bike can roll, like its in neutral. I have a baaad feeling that this is going to be monumentally expensive.

    Does anyone know what this might be, even an educated guess?
    Thanks in advance.
     
  2. tourbox

    tourbox Senior Member

    1,307
    68
    54
    If you can roll the bike in any gear with the clutch out as in neutral then I would lean to the primary/clutch. Seeing as you say has power but will the bike(motor?) will not turn over, does the starter turn on/over? I would start with the primary from what you have stated. A broken rear drive belt will act like neutral in any gear but yours isn't running.
    tourbox
     
  3. 2manycats

    2manycats Member

    15
    0
    0
    The belt is ok. No, the starter doesn't turn over.
     
  4. ciscokid

    ciscokid Member

    72
    0
    0
    open up that primary something let loose. prob busted the case. any oil leaking
     
  5. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,275
    133
    156
    The description of the problem does point to a problem of some sort in the primary only able to speculate what might be wrong so best to open the primary and see what is going on

    Brian
     
  6. Breeze3at

    Breeze3at Well-Known Member

    4,641
    83
    122
    I'm really interested in this one. NOTHING from the starter? click, headlights dim? It's like two totally different problems.
     
  7. r_k_dragon

    r_k_dragon Active Member

    270
    0
    4
    More info please. Cruising level? Passing? Hard throttle up? Power for lights? What? Drifted to the berm without pulling in the clutch? Did you try gearing down during this or ...? Any more wouldn't hurt and may help.
     
  8. 2manycats

    2manycats Member

    15
    0
    0
    Nothing from the starter at all. Checked all fuses and connections. All lights work, display, horn, etc. When this happened the 'engine' light came on, and now it comes on and stays on, until the key is off.
     
  9. Breeze3at

    Breeze3at Well-Known Member

    4,641
    83
    122
    I got NUTHIN,,, not even a crazy off the wall suggestion. But I'm watching. :)
     
  10. 2manycats

    2manycats Member

    15
    0
    0
    Cruising at a steady 65 on flat road. As I was pulling over, I went through the gears-nuthin'. It was like every gear was a 'neutral'.