back firing and popping out breather

Discussion in 'Engine, Fuel and Exhaust' started by hdin5, Jun 16, 2008.

  1. hdin5

    hdin5 Member

    5
    11
    0
    i have an 03 flht with 16000 miles on it, i just installed a set of vance and hines true duals and put d and d slip ons on it, it has a stage 1 breather kit installed. im having trouble with it popping out the breather at 2000 rpms. found a bad rear injector replaced it and it ran good for 60 miles. back to the same problem. replaced the intake gaskets with s&s gaskets and it ran great for 200 miles, now back to the same problem. it also snaps and cracks out the rear cylinder exhaust pipe. does any have suggestions? seems to be common ground in the intake area. when work is done it runs good for a while then we go back to the original problem. thanks to all, this is a great forum....
     
  2. Fisher

    Fisher Account Removed

    341
    0
    1
    Did you install the Harley air cleaner?Did you accomodate the additional air by race tuner,powercommander or some type of FI mod?
     
  3. hdin5

    hdin5 Member

    5
    11
    0
    we installed a 1550 stage 1 down load in to help richin up. it ran great but after 60 miles went back to the same problem.
     
  4. hdin5

    hdin5 Member

    5
    11
    0
    the stage 1 harley air cleaner was also installed.
     
  5. Doc 1

    Doc 1 Member

    51
    18
    1
    The bike needs to have a recording done to see what sensor is out of it's parameters when the trouble starts.
     
  6. hdin5

    hdin5 Member

    5
    11
    0
    could it be the heat sensor that is attached to the front cylinder?

    also once the bike goes into its fit it remains there, its not something that comes and goes,,,, appreciate all the info.
     
  7. cdn-bigfoot

    cdn-bigfoot Junior Member

    645
    26
    1
    Ensure your exhaust is correctly sealed and tight.

    Did you install new exhaust gaskets at the flanges?
     
    Last edited: Jun 16, 2008
  8. hdin5

    hdin5 Member

    5
    11
    0
    i will definately check the pipes at the heads, i installed new gaskets with the pipes, thanks alot u guys are a great help.
     
  9. Derekj

    Derekj Member

    36
    16
    0
    check your crank position censor.