At Wits End , Decel Popping/Backfiring

Discussion in 'Engine, Fuel and Exhaust' started by antrom, Apr 19, 2009.

  1. antrom

    antrom Member

    11
    11
    0
    I have an 07 Road King Classic with a Big Sucker filter, Vance and Hines Dresser Ovals, and a PCV. I am at my wits end, the bike is popping/backfiring on decel. I had an exhaust leak between the muffler and the head pipe (fixed it). Jaime from Fuel Moto has sent me 3 different maps (to no avail). The popping persists whether I run the bike lean or rich. Yesterday, after I fixed the exhaust leak the
    bike threw a couple of codes "p1353- front cyl no combustion, and u1097-Loss of speedometer serial data"
    Also my fuel mileage has declined significantly, when the Power Comander was installed I initially got 27 mpg, I am currently getting 35 mpg with what is supposed to be a fairly lean map.

    I am thinking that my timing may be off, but that is just a guess. Can anybody give me some advice, or maybe point me in the right direction ?
     
  2. Bud White

    Bud White Well-Known Member Retired Moderators

    3,271
    48
    2
    Claer the codes see if they come back if so work on them first after removing and installing the PC connections to make sure tis not a connection error the fuel milage you are getting is a joke .. I have true dual kit 2" baffels big sucker on a 08 rkc if i control the right hand i can get 40+ on highway round town again controlling the hand 34-39 ..

    if your getting popping on decel why are they sending your leaner fuel maps?
     
  3. antrom

    antrom Member

    11
    11
    0
    I cleared the codes, but have not run the bike since. I will try that shortly. They sent the leaner maps to try and adress the fuel mileage ( they leaned it out at 0% throttle from 2500 rpms on up to try and adress the popping). A little more info, the bike was popping long before the codes showed up.
     
  4. Bud White

    Bud White Well-Known Member Retired Moderators

    3,271
    48
    2
    popping on decel is usually to lean or the exhust leak you had can cause it to .. how do plugs look etc.. like i said the mileage is way to low
     
  5. Bud White

    Bud White Well-Known Member Retired Moderators

    3,271
    48
    2
    Check you map and see if they timing has been fooled with in the Power commander
     
  6. antrom

    antrom Member

    11
    11
    0
    I haven't messed with the timing, I don't know why it may or may not be off. Just trying to think of possible causes. Checked the pc connections, and reconnected the unit. Going for a test ride shortly. I will post the results. How can I check the air cleaner for leaks ?

    Plugs look fine, sort of a golden brownish color, a little black toward the end.

    I sure do appreciate all of the input!
     
    Last edited: Apr 19, 2009
  7. Bud White

    Bud White Well-Known Member Retired Moderators

    3,271
    48
    2
    spray wd around the intake where it bolts to head
     
  8. antrom

    antrom Member

    11
    11
    0
    Checked the air cleaner and, rechecked the exhaust for leaks(none found), rechecked pc connections. Still getting the popping. Any suggestions?
     
  9. rkf09fxdb

    rkf09fxdb Member

    61
    16
    0
    I've got the PC V on my Street bob. I downloaded my maps from the PC V web site. You might want to check with them and see what they say. My street bob backfires once and a while, but not very often.


    Correct me if I'm wrong. Isn't the PC-V for select 2009 Harleys only? On the web site it does not show maps for a 2007 RK for the PC-V. Unless I'm looking in the wrong place.:eam
     
  10. rkf09fxdb

    rkf09fxdb Member

    61
    16
    0
    So this might be an issue since it is on a 2007 RK.:eam I know that fuelmoto sells retrofit units and they know what they are doing I was just wondering.
     
    Last edited: Apr 20, 2009