alternator or regulator?

Discussion in 'Sportster Models' started by piratesson, Dec 19, 2010.

  1. piratesson

    piratesson New Member

    3
    0
    0
    I have a 89 sporty and my battery is only showing 11 volts when running after I bought a new battery... It's not charging. It has to be either the alternator or regulator, but is there anyway to tell without having to tear the bike apart and looking at the alternator? or should i just buy the cheaper of the two and hope it's it?

    By the way, I Checked all the connections already and they are all good
     
  2. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
  3. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,277
    133
    156
    As i remember the charging system on this age of sportster has the rotor built into the clutch basket and the stator behind that having previously had a charging issue on an 87 sportster i went for the simple option to start with and replaced the regulator sorted owner was happy as bill for parts was under £ 100 rather than a possible of around £700 for the replacement clutch basket and stator

    Brian
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Im with Brian on this one, most times when voltage is that low it is a bad regulator and it is the lesser of the two evils so to speak
     
  5. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Sadly, if the regulator fixes it...that means the stator was stressed, and the battery if allowed to fully discharge will lose some of it's reserve too. So keep an eye on that charging voltage and when you use a battery tender...see how long it takes to go from yellow/red flashing to green. If your battery and charging system is reasonably up to to snuff it will usually go to green in about 15 minutes.:s
     
  6. piratesson

    piratesson New Member

    3
    0
    0
    Thanks so much! I went ahead and bought the regulator because my distrubutor went out like a month ago as well so I thought maybe the probelms were connected... I'm going to check the plug coming fromt he alternator to see if its doing anything now.

    Thanks again!!!