All Electa Glide Gauges Stopped Working

Discussion in 'Touring Models' started by chuckt121, Sep 17, 2012.

  1. chuckt121

    chuckt121 Member

    7
    0
    0
    I have a similar problem.I have a 2005 ultra classic.ALL of the guages stopped working. This happened once before but after a short ride they started working again. This time I rode about 200 miles and they still dont work. The fuses are all ok and and the turn signals cancel on thier own.my local dealer says they don't know what would cause it. Any suggestions would be appreciated.
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Re: Speed Sensor Pickup Problem Symptoms

    So does this mean the turn signals are working properly? There may be a problem inside the inner fairing, has any work been done in there?
     
  3. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Re: Speed Sensor Pickup Problem Symptoms

    I own a Dyna. "All" is meaningless to me. List the gauges that are not working along with the ones that are still working. Is the back lighting for the gauges also missing.
     
  4. chuckt121

    chuckt121 Member

    7
    0
    0
    Re: Speed Sensor Pickup Problem Symptoms

    The signals ARE working fine. I read somewhere that it may be a speed sensor. I changed that today and still no luck.I pulled the fairing off and and checked every connection there. they are all tight, no pinched wires located. I also read about an onboard diagnostic test done by holding the odometer trip button. the speedo guage is supposed to sweep then return and codes should come up. the speedo never moved.there is a very slight flicker on the speedo but barely perceptible when the switch is turned on.
     
  5. chuckt121

    chuckt121 Member

    7
    0
    0
    Re: Speed Sensor Pickup Problem Symptoms

    ok the speedometer ,oil pressure,air,tach,directionals, odometer, nutral, fuel and volt meter are not working. the backlights are working.
     
  6. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Re: Speed Sensor Pickup Problem Symptoms

    I am trying to help you. "Signals" to me are directional lights.
    There is a signal light. There is a signal light indicator. I am looking at schematics. You want an accurate answer? I need accurate information.
     
  7. turnerbend

    turnerbend Active Member

    231
    38
    3
    Check battery voltage...
     
  8. chuckt121

    chuckt121 Member

    7
    0
    0
    Re: Speed Sensor Pickup Problem Symptoms

    Im sorry, I meant the directional indicator(meaning the green arrow in the cluster) is working as well as the actual directional lights.the self cancelling works when the directional lights are applied . I hope this helps and thank you for your help.
     
  9. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    y local dealer says they don't know what would cause it.
    Code:
    
    
    What did they base this on and how much time did they spend on the bike?
     
  10. chuckt121

    chuckt121 Member

    7
    0
    0
    I spoke with a mechanic there but didn't put it in the shop. I'm not exactly happy with work completed (or should I say not completed) in the past. I had hoped for a few ideas that I could check at home. he based it on a description of what had happened when the went out before then worked for a while.