Accessorie Switch lost Power

Discussion in 'Touring Models' started by c.tennant, Jun 28, 2011.

  1. c.tennant

    c.tennant New Member

    3
    0
    0
    I have a 2008 FLHX, was using my GPS and had it pluged in to the cig lighter. The power plug to the GPS came apart while it was pluged into the cig lighter and did something to the accessorie switch power. I checked the fuse and it was fine. Also have Pod lights around the engine hooked to the accessorie switch and no power to them also. Anyone have any clue what could be going on?
     
  2. TripleJ

    TripleJ Senior Member

    1,081
    48
    8
    How did you check the fuse? Use a test light or DVOM to test for power. Visually checking a fuse can be misleading. If no test light or DVOM replace the fuse with a new one and see if that works.
     
  3. glider

    glider Veteran Member

    25,464
    108
    44
    Did you check an inline fuse or a fuse in the fuse panel? Always check with a test light on both sides of the fuse when powered up.
     
  4. c.tennant

    c.tennant New Member

    3
    0
    0
    pulled old fuse and put a new one in. No power. where is the inline fuse?
     
  5. glider

    glider Veteran Member

    25,464
    108
    44
    Usually in the line near the unit itself or near it if there is one.
     
  6. c.tennant

    c.tennant New Member

    3
    0
    0
    do the put an inline fuse at the accessorie switch? Cig lighter to??
     
  7. glider

    glider Veteran Member

    25,464
    108
    44
    There is a POSSIBILITY of having an inline fuse in some installations depending on who installed the unit.